aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xinput-calibrator/xinput-calibrator-0.5.0
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-01-19 16:28:28 +0100
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-01-19 16:36:16 +0100
commitb28038e8136bab6c93fd39e199105a72149b8edb (patch)
tree48ac1cfb4e5399754e908435a73f0731b0d4aeb2 /recipes/xinput-calibrator/xinput-calibrator-0.5.0
parent192d40a9c1149605443ac267a09b7f76afd571e2 (diff)
downloadopenembedded-b28038e8136bab6c93fd39e199105a72149b8edb.tar.gz
xinput-calibrator: added 0.5.0
This is tool to calibrate touchscreens which works as XInput devices (evdev, evtouch, ... but not tslib one). So far only X11 version, GTKmm one will be provided later by Petr Štetiar.
Diffstat (limited to 'recipes/xinput-calibrator/xinput-calibrator-0.5.0')
-rw-r--r--recipes/xinput-calibrator/xinput-calibrator-0.5.0/use-proper-compiler.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/xinput-calibrator/xinput-calibrator-0.5.0/use-proper-compiler.patch b/recipes/xinput-calibrator/xinput-calibrator-0.5.0/use-proper-compiler.patch
new file mode 100644
index 0000000000..a7912fb4c7
--- /dev/null
+++ b/recipes/xinput-calibrator/xinput-calibrator-0.5.0/use-proper-compiler.patch
@@ -0,0 +1,20 @@
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- git.orig/Makefile
++++ git/Makefile
+@@ -1,11 +1,11 @@
+ all: x11 gtkmm
+
+ x11: main_x11.cpp gui_x11.cpp
+- g++ -Wall main_x11.cpp -lX11 -lXi -o xinput_calibrator.x11
++ $(CXX) $(CFLAGS) $(LDFLAGS) -Wall main_x11.cpp -lX11 -lXi -o xinput_calibrator.x11
+ cp xinput_calibrator.x11 xinput_calibrator
+
+ gtkmm: main_gtkmm.cpp gui_gtkmm.cpp
+- g++ -Wall main_gtkmm.cpp `pkg-config --cflags --libs gtkmm-2.4` -o xinput_calibrator.gtkmm
++ $(CXX) $(CFLAGS) $(LDFLAGS) -Wall main_gtkmm.cpp `pkg-config --cflags --libs gtkmm-2.4` -o xinput_calibrator.gtkmm
+
+ clean:
+ rm -f xinput_calibrator xinput_calibrator.x11 xinput_calibrator.gtkmm