aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xinetd/xinetd_2.3.13.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xinetd/xinetd_2.3.13.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xinetd/xinetd_2.3.13.bb')
-rw-r--r--recipes/xinetd/xinetd_2.3.13.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/xinetd/xinetd_2.3.13.bb b/recipes/xinetd/xinetd_2.3.13.bb
new file mode 100644
index 0000000000..d6d42223d0
--- /dev/null
+++ b/recipes/xinetd/xinetd_2.3.13.bb
@@ -0,0 +1,40 @@
+DEPENDS = ""
+DESCRIPTION = "Highly configurable, modular and secure inetd"
+PR ="r4"
+
+SRC_URI = "http://www.xinetd.org/xinetd-${PV}.tar.gz \
+ file://xinetd.init \
+ file://xinetd.conf \
+ file://service.c.patch;patch=1 \
+ "
+
+EXTRA_OECONF="--disable-nls"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "xinetd"
+INITSCRIPT_PARAMS = "defaults"
+
+do_configure() {
+ # Looks like configure.in is broken, so we are skipping
+ # rebuilding configure and are just using the shipped one
+ oe_runconf
+}
+
+INHIBIT_AUTO_STAGE = "1"
+
+do_install() {
+ # Same here, the Makefile does some really stupid things,
+ # but since we only want two files why not override
+ # do_install from autotools and doing it ourselfs?
+ install -d "${D}/usr/sbin"
+ install -d "${D}/etc/init.d"
+ install -d "${D}/etc/xinetd.d"
+ install -m 644 "${WORKDIR}/xinetd.conf" "${D}/etc"
+ install -m 755 "${WORKDIR}/xinetd.init" "${D}/etc/init.d/xinetd"
+ install -m 755 "${S}/xinetd/xinetd" "${D}/usr/sbin"
+ install -m 755 "${S}/xinetd/itox" "${D}/usr/sbin"
+
+}
+
+CONFFILES_${PN} = "${sysconfdir}/xinetd.conf"