aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wxsqlite3
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-01-21 23:36:04 -0800
committerKhem Raj <raj.khem@gmail.com>2010-01-21 23:38:59 -0800
commit9b7a3d25ba359978b1568fd64300aa37f8294de2 (patch)
tree08736df679e54c0761dff2951ebb3efed86e5613 /recipes/wxsqlite3
parente140696df4b677dd30b8345a79ad02137d63489d (diff)
downloadopenembedded-9b7a3d25ba359978b1568fd64300aa37f8294de2.tar.gz
wxsqlite3: Add version 1.9.7 recipe.
* Fix linker failure due to gcc inline issue (gcc-inline.patch). * Fix broken unicode builds (wxtranslate.patch). Signed-off-by: Johan Hovold <johan.hovold@lundinova.se> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/wxsqlite3')
-rw-r--r--recipes/wxsqlite3/wxsqlite3-1.9.7/gcc-inline.patch29
-rw-r--r--recipes/wxsqlite3/wxsqlite3-1.9.7/wxtranslate.patch11
-rw-r--r--recipes/wxsqlite3/wxsqlite3_1.9.7.bb25
3 files changed, 65 insertions, 0 deletions
diff --git a/recipes/wxsqlite3/wxsqlite3-1.9.7/gcc-inline.patch b/recipes/wxsqlite3/wxsqlite3-1.9.7/gcc-inline.patch
new file mode 100644
index 0000000000..10338ad00d
--- /dev/null
+++ b/recipes/wxsqlite3/wxsqlite3-1.9.7/gcc-inline.patch
@@ -0,0 +1,29 @@
+diff -pru wxsqlite3-1.9.7.orig/include/wx/wxsqlite3.h wxsqlite3-1.9.7/include/wx/wxsqlite3.h
+--- wxsqlite3-1.9.7.orig/include/wx/wxsqlite3.h 2009-11-09 20:59:38.000000000 +0100
++++ wxsqlite3-1.9.7/include/wx/wxsqlite3.h 2009-12-06 17:19:58.000000000 +0100
+@@ -94,7 +94,7 @@ public:
+ int GetExtendedErrorCode() const { return m_errorCode; }
+
+ /// Get error message associated with the exception
+- const wxString GetMessage() const { return m_errorMessage; }
++ const wxString GetMessage() const;
+
+ /// Convert error code to error message
+ static const wxString ErrorCodeAsString(int errorCode);
+Only in wxsqlite3-1.9.7: patches
+diff -pru wxsqlite3-1.9.7.orig/src/wxsqlite3.cpp wxsqlite3-1.9.7/src/wxsqlite3.cpp
+--- wxsqlite3-1.9.7.orig/src/wxsqlite3.cpp 2009-11-09 20:59:38.000000000 +0100
++++ wxsqlite3-1.9.7/src/wxsqlite3.cpp 2009-12-06 17:58:01.000000000 +0100
+@@ -263,6 +263,11 @@ wxSQLite3Exception::~wxSQLite3Exception(
+ {
+ }
+
++const wxString wxSQLite3Exception::GetMessage() const
++{
++ return m_errorMessage;
++}
++
+ // ----------------------------------------------------------------------------
+ // wxSQLite3StatementBuffer: class providing a statement buffer
+ // for use with the SQLite3 vmprintf function
+Only in wxsqlite3-1.9.7/src: .wxsqlite3.cpp.swp
diff --git a/recipes/wxsqlite3/wxsqlite3-1.9.7/wxtranslate.patch b/recipes/wxsqlite3/wxsqlite3-1.9.7/wxtranslate.patch
new file mode 100644
index 0000000000..b40511cf05
--- /dev/null
+++ b/recipes/wxsqlite3/wxsqlite3-1.9.7/wxtranslate.patch
@@ -0,0 +1,11 @@
+--- wxsqlite3-1.9.7.orig/src/wxsqlite3.cpp 2009-11-09 20:59:38.000000000 +0100
++++ wxsqlite3-1.9.7/src/wxsqlite3.cpp 2009-12-06 17:58:35.000000000 +0100
+@@ -94,6 +94,8 @@ static void InitSQLite3DLL()
+
+ // Error messages
+
++#undef wxTRANSLATE
++#define wxTRANSLATE wxT
+ const wxChar* wxERRMSG_NODB = wxTRANSLATE("No Database opened");
+ const wxChar* wxERRMSG_NOSTMT = wxTRANSLATE("Statement not accessible");
+ const wxChar* wxERRMSG_NOMEM = wxTRANSLATE("Out of memory");
diff --git a/recipes/wxsqlite3/wxsqlite3_1.9.7.bb b/recipes/wxsqlite3/wxsqlite3_1.9.7.bb
new file mode 100644
index 0000000000..5f7d3c9cdd
--- /dev/null
+++ b/recipes/wxsqlite3/wxsqlite3_1.9.7.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "A wxWindows wrapper for the sqlite database."
+HOMEPAGE = "http://wxcode.sourceforge.net/components/wxsqlite3"
+SECTION = "libs"
+LICENSE = "wxWindows"
+DEPENDS = "sqlite3 wxwidgets"
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wxcode/wxsqlite3-${PV}.tar.gz;name=wxsqlite3 \
+ file://gcc-inline.patch;patch=1 \
+ file://wxtranslate.patch;patch=1 \
+ "
+SRC_URI[wxsqlite3.md5sum] = "2e1bec387bbdf50c632649d041b32a4a"
+SRC_URI[wxsqlite3.sha256sum] = "eaee8290c1f386413f5cb1e1af9ec4e7573c1dcce2760d79f4276497a75c4f64"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-sqlite3-prefix=${STAGING_LIBDIR}"
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+ newincludedir=${D}/${includedir}/wx-$(wx-config --release)
+ mkdir "$newincludedir"
+ mv ${D}/${includedir}/wx "$newincludedir"
+}