aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wt/wt3-3.0.0
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-11-12 19:09:03 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-11-12 19:22:48 +0100
commitc29c0219c02010493d241113f8c9718eee6fc269 (patch)
tree65e8c287ee0f8dbb8d244e58edb3633d4ac0f1ca /recipes/wt/wt3-3.0.0
parent58b64b531900ef438a2d4b90cc1c10550d30862b (diff)
downloadopenembedded-c29c0219c02010493d241113f8c9718eee6fc269.tar.gz
wt3: update to version 3.0.0
* spilt up with .inc-file and switch to INC_PR * disable qt explicit in CMakeLists.txt
Diffstat (limited to 'recipes/wt/wt3-3.0.0')
-rw-r--r--recipes/wt/wt3-3.0.0/noqt.patch19
-rw-r--r--recipes/wt/wt3-3.0.0/wgooglemap.patch17
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes/wt/wt3-3.0.0/noqt.patch b/recipes/wt/wt3-3.0.0/noqt.patch
new file mode 100644
index 0000000000..48231246d3
--- /dev/null
+++ b/recipes/wt/wt3-3.0.0/noqt.patch
@@ -0,0 +1,19 @@
+Index: wt-3.0.0/CMakeLists.txt
+===================================================================
+--- wt-3.0.0.orig/CMakeLists.txt 2009-11-12 18:50:12.087842114 +0100
++++ wt-3.0.0/CMakeLists.txt 2009-11-12 18:50:42.023261611 +0100
+@@ -111,10 +111,10 @@
+ INCLUDE(cmake/WtFindSsl.txt)
+ INCLUDE(cmake/WtFindMysqlpp.txt)
+
+-FIND_PACKAGE(Qt4)
+-IF(QT_FOUND)
+- INCLUDE(${QT_USE_FILE})
+-ENDIF(QT_FOUND)
++#FIND_PACKAGE(Qt4)
++#IF(QT_FOUND)
++# INCLUDE(${QT_USE_FILE})
++#ENDIF(QT_FOUND)
+
+ # Boost is used nearly everywhere, so we can put these here
+ INCLUDE_DIRECTORIES(${BOOST_INCLUDE_DIRS})
diff --git a/recipes/wt/wt3-3.0.0/wgooglemap.patch b/recipes/wt/wt3-3.0.0/wgooglemap.patch
new file mode 100644
index 0000000000..6827afbbe7
--- /dev/null
+++ b/recipes/wt/wt3-3.0.0/wgooglemap.patch
@@ -0,0 +1,17 @@
+Index: wt-3.0.0/src/Wt/WGoogleMap.C
+===================================================================
+--- wt-3.0.0.orig/src/Wt/WGoogleMap.C 2009-09-01 17:46:54.000000000 +0200
++++ wt-3.0.0/src/Wt/WGoogleMap.C 2009-11-12 16:23:39.614976154 +0100
+@@ -26,6 +26,12 @@
+ using std::min;
+ using std::max;
+
++#if not defined(_GLIBCXX_HAVE__SINL) && not defined(acosl)
++#define cosl cos
++#define acosl acos
++#define sinl sin
++#endif
++
+ #ifndef M_PI
+ #define M_PI 3.14159265358979323846
+ #endif