aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vlc/vlc-davinci_0.8.6h.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/vlc/vlc-davinci_0.8.6h.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/vlc/vlc-davinci_0.8.6h.bb')
-rw-r--r--recipes/vlc/vlc-davinci_0.8.6h.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/recipes/vlc/vlc-davinci_0.8.6h.bb b/recipes/vlc/vlc-davinci_0.8.6h.bb
new file mode 100644
index 0000000000..71520bbb9b
--- /dev/null
+++ b/recipes/vlc/vlc-davinci_0.8.6h.bb
@@ -0,0 +1,63 @@
+DESCRIPTION = "Video player and streamer - davinci edition"
+HOMEPAGE = "http://www.videolan.org"
+LICENSE = "GPL"
+PRIORITY = "optional"
+SECTION = "multimedia"
+
+SRCREV = "e712a114e04a1070f1afdf31ec668cb28eda513c"
+
+PR = "r6"
+
+PV = "0.8.6h+${PR}+gitr${SRCREV}"
+
+DEPENDS = "codec-engine dbus libxml2 gnutls tremor faad2 ffmpeg flac \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag liba52 mpeg2dec', d)}"
+
+SRC_URI = "git://git.videolan.org/vlc.git;protocol=git;branch=0.8.6-neuros"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+EXTRA_OECONF = "\
+ --enable-libtool \
+ --with-contrib \
+ --disable-dvdread \
+ --disable-wxwidgets \
+ --disable-skins2 \
+ --disable-libmpeg2 \
+ --disable-dvdnav \
+ --disable-x11 --disable-xvideo --disable-opengl --disable-glx \
+ --disable-screen --disable-caca \
+ --disable-httpd --disable-vlm \
+ --disable-freetype \
+ --disable-sdl \
+ --enable-png \
+ --enable-live555 --enable-tremor \
+ --disable-mod \
+ --enable-davinci --enable-davincifb --enable-davinciresizer \
+ --enable-v4l2 --disable-aa --enable-wma --disable-faad \
+ --enable-dbus \
+"
+
+
+do_configure() {
+ ./bootstrap
+ gnu-configize
+ libtoolize --force
+ autoreconf --force -i
+ oe_runconf
+ rm config.log
+ sed -i -e s:-L/usr/lib:-L${STAGING_LIBDIR}/:g vlc-config
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+RCONFLICTS_${PN} = "vlc"
+
+FILES_${PN} += "${bindir}/vlc \
+ ${datadir}/applications \
+ ${datadir}/vlc/ \
+ "