aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vim/vim.inc
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@buglabs.net>2010-04-01 19:06:55 +0200
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-04-01 19:12:07 +0200
commit53c1e459d24cffbcb4b7e4886a69f91fa5c7c4b7 (patch)
tree5a9361d7b81fcd7880ee68119016eaefa3bf3e73 /recipes/vim/vim.inc
parent90a0e239a579edbd7747e610a85c9e5b556263e8 (diff)
downloadopenembedded-53c1e459d24cffbcb4b7e4886a69f91fa5c7c4b7.tar.gz
vim: updated to 7.2.394, dropped older versions, cleaned recipes
I added 394 upstream patches to vim into metadata as checksums for them would be bigger then patch itself. Older (6.2, 6.4, 7.0) versions got dropped as they can have security problems and no one maintains them. Recipes for 7.2 got cleaned - we have gvim, vim-tiny and vim now. Main code is split between vim.inc and vim_7.2.bb files. Adding new variants is now easier due to VIMFEATURES, VIMX and VIMGUI variables. EXTRA_OECONF variables were generated by running vim configure script on BUG 2.0 device. Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/vim/vim.inc')
-rw-r--r--recipes/vim/vim.inc58
1 files changed, 43 insertions, 15 deletions
diff --git a/recipes/vim/vim.inc b/recipes/vim/vim.inc
index 9eb0b80c0e..185b599073 100644
--- a/recipes/vim/vim.inc
+++ b/recipes/vim/vim.inc
@@ -1,39 +1,67 @@
-DESCRIPTION = "Vim is an almost fully-compatible version of the Unix editor Vi."
+DESCRIPTION = "Vi IMproved - enhanced vi editor"
SECTION = "console/utils"
DEPENDS = "ncurses"
# vimdiff doesn't like busybox diff
RSUGGESTS_${PN} = "diffutils"
LICENSE = "vim"
-INC_PR = "r4"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/vim-${PV}"
-SRC_URI = "ftp://ftp.vim.org/pub/vim/unix/vim-${PV}.tar.bz2 \
- file://configure.patch;patch=1"
+INC_PR = "r5"
+
+SRC_URI = "ftp://ftp.vim.org/pub/vim/unix/vim-${PV}.tar.bz2;name=vim${PV}tarbz2 \
+ ftp://ftp.vim.org/pub/vim/extra/vim-${PV}-extra.tar.gz;name=vim${PV}extratargz \
+ ftp://ftp.vim.org/pub/vim/extra/vim-${PV}-lang.tar.gz;name=vim${PV}langtargz "
S = "${WORKDIR}/vim${VIMVER}/src"
inherit autotools update-alternatives
+# vim configure.in contains functions which got 'dropped' by autotools.bbclass
do_configure () {
- rm -f auto/*
- touch auto/config.mk
- aclocal
- autoconf
- oe_runconf
- touch auto/configure
- touch auto/config.mk auto/config.h
+ rm -f auto/*
+ touch auto/config.mk
+ aclocal
+ autoconf
+ oe_runconf
+ touch auto/configure
+ touch auto/config.mk auto/config.h
}
+
+
+VIMFEATURES ?= "big"
+VIMX ?= "--without-x"
+VIMGUI ?= "none"
+
+EXTRA_OECONF = "--enable-gui=${VIMGUI} --disable-gtktest \
+ --disable-xim --with-features=${VIMFEATURES} \
+ --disable-gpm ${VIMX} --disable-netbeans \
+ ac_cv_small_wchar_t="no" \
+ vim_cv_getcwd_broken=no \
+ vim_cv_memmove_handles_overlap=yes \
+ vim_cv_stat_ignores_slash=no \
+ vim_cv_terminfo=yes \
+ vim_cv_tgent=non-zero \
+ vim_cv_toupper_broken=no \
+ vim_cv_tty_group=world \
+ --with-tlib=ncurses"
+
PACKAGES =+ "vim-common vim-syntax vim-help vim-tutor"
FILES_vim-syntax = "${datadir}/vim/vim${VIMVER}/syntax"
FILES_vim-help = "${datadir}/vim/vim${VIMVER}/doc"
FILES_vim-tutor = "${datadir}/vim/vim${VIMVER}/tutor ${bindir}/vimtutor"
-#FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
-# ${libdir}/*/ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
-# /bin /sbin /lib/*/ /lib/*.so* ${datadir}/vim"
-
ALTERNATIVE_NAME = "vi"
ALTERNATIVE_PATH = "${bindir}/vim"
ALTERNATIVE_LINK = "${base_bindir}/vi"
ALTERNATIVE_PRIORITY = "100"
+
+SRC_URI[vim7.2tarbz2.md5sum] = "f0901284b338e448bfd79ccca0041254"
+SRC_URI[vim7.2tarbz2.sha256sum] = "914db0f2205ebd6f02878295ec2506036ea7500399db112c61a01491cd9a1d86"
+SRC_URI[vim7.2langtargz.md5sum] = "d8884786979e0e520c112faf2e176f05"
+SRC_URI[vim7.2langtargz.sha256sum] = "11607f539a4518b550bf1606b7d3a6f36c1ffdf566c058e7d94bced78034cd5b"
+SRC_URI[vim7.2extratargz.md5sum] = "35e04482f07c57221c9a751aaa3b8dac"
+SRC_URI[vim7.2extratargz.sha256sum] = "20894ac79672160bfc4f1d2f9f9775b34d944762d655307a91ca96d358faa04d"
+
+PARALLEL_MAKE = ""