aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/unifdef/unifdef_2.6.bb
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2011-02-25 07:49:53 -0700
committerChris Larson <chris_larson@mentor.com>2011-02-25 08:14:16 -0700
commit4614343e9455ef154a18826c57cbd9474858da27 (patch)
tree6446b925df4786069f072cb02fe1d6939b963885 /recipes/unifdef/unifdef_2.6.bb
parent311aa1c4fc2f2f34c1d3abc6093df18ff26bb935 (diff)
downloadopenembedded-4614343e9455ef154a18826c57cbd9474858da27.tar.gz
unifdef: update from 2.4 to 2.6
As far as I can see, all the changes are bugfixes, and only one of those affects behavior in a noticable way to the user (-o now obeys -n, emitting line numbers to the specified output file). Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/unifdef/unifdef_2.6.bb')
-rw-r--r--recipes/unifdef/unifdef_2.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/unifdef/unifdef_2.6.bb b/recipes/unifdef/unifdef_2.6.bb
new file mode 100644
index 0000000000..0fb40956ae
--- /dev/null
+++ b/recipes/unifdef/unifdef_2.6.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "selectively remove C preprocessor conditionals"
+HOMEPAGE = "http://dotat.at/prog/unifdef/"
+# The sources are under the 2 clause BSD license, the man page is under
+# the 3 clause BSD license.
+LICENSE = "BSD"
+PR = "0"
+
+SRC_URI = "http://dotat.at/prog/unifdef/unifdef-${PV}.tar.gz"
+SRC_URI[md5sum] = "18b832baea2c7b6b00bd7d4f3db38f62"
+SRC_URI[sha256sum] = "e4cbc673d32ebe10e00bc00b985c974e327e65d4b32a564d21358e458079e419"
+
+
+EXTRA_OEMAKE = "-e"
+
+do_install () {
+ oe_runmake 'man1dest=${D}${mandir}/man1' \
+ 'bindest=${D}${bindir}' \
+ install
+}
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND += "native nativesdk"