summaryrefslogtreecommitdiffstats
path: root/recipes/udev/acl-2.2.49/nolargefile.patch
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-12-21 12:54:49 +0000
committerKhem Raj <raj.khem@gmail.com>2010-12-25 03:18:30 -0800
commiteee20f64cd7b76ae41acf1af0fac30d01c7c3572 (patch)
tree82e7f1dd2c7c478f16b5827b25c69995a44d218b /recipes/udev/acl-2.2.49/nolargefile.patch
parent7dfd4e0a25d97d6ef2940541573d5fd282329c9e (diff)
downloadopenembedded-eee20f64cd7b76ae41acf1af0fac30d01c7c3572.tar.gz
acl_2.2.49.bb: Fix build when DISTRO_FEATURES lacks largefile.
Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/udev/acl-2.2.49/nolargefile.patch')
-rw-r--r--recipes/udev/acl-2.2.49/nolargefile.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/udev/acl-2.2.49/nolargefile.patch b/recipes/udev/acl-2.2.49/nolargefile.patch
new file mode 100644
index 0000000000..272b97e22f
--- /dev/null
+++ b/recipes/udev/acl-2.2.49/nolargefile.patch
@@ -0,0 +1,15 @@
+--- acl-2.2.49/chacl/chacl.c.orig 2010-12-21 14:00:42.563984943 +1030
++++ acl-2.2.49/chacl/chacl.c 2010-12-21 14:01:15.614983219 +1030
+@@ -315,6 +315,12 @@
+ return(failed);
+ }
+
++#ifndef __USE_LARGEFILE64
++/* XXX: hack! */
++#define dirent64 dirent
++#define readdir64 readdir
++#endif
++
+ static int
+ walk_dir(acl_t acl, acl_t dacl, const char *fname)
+ {