aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tzcode/tzcode-native.inc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-09-18 17:11:45 -0700
committerKhem Raj <raj.khem@gmail.com>2009-09-18 17:13:53 -0700
commit82e740b54d24abc4a4b93d60d2d5b5e96432e128 (patch)
treef2d6fd5d29c38c8e87e72ab9bbdd752221445d82 /recipes/tzcode/tzcode-native.inc
parenta95c355af46bdc395cc8e1141682ab802ac48130 (diff)
downloadopenembedded-82e740b54d24abc4a4b93d60d2d5b5e96432e128.tar.gz
tzcode-native_2009k.bb, tzdata_2009m.bb: New timezone data
* Add new recipes for latest zoneinfo data * Resort to INC_PR * Abstract out common parts into .inc files. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/tzcode/tzcode-native.inc')
-rw-r--r--recipes/tzcode/tzcode-native.inc17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/tzcode/tzcode-native.inc b/recipes/tzcode/tzcode-native.inc
new file mode 100644
index 0000000000..8d3d6ddee7
--- /dev/null
+++ b/recipes/tzcode/tzcode-native.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
+INC_PR = "r1"
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_stage () {
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 755 zic ${STAGING_BINDIR_NATIVE}/
+ install -m 755 zdump ${STAGING_BINDIR_NATIVE}/
+ install -m 755 tzselect ${STAGING_BINDIR_NATIVE}/
+}
+
+do_install () {
+ :
+}