aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tickypip/tickypip_0.1.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tickypip/tickypip_0.1.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tickypip/tickypip_0.1.2.bb')
-rw-r--r--recipes/tickypip/tickypip_0.1.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/tickypip/tickypip_0.1.2.bb b/recipes/tickypip/tickypip_0.1.2.bb
new file mode 100644
index 0000000000..558828e919
--- /dev/null
+++ b/recipes/tickypip/tickypip_0.1.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Tickypip"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "Christian Hammond"
+HOMEPAGE = "http://www.chipx86.com/projects/tickypip/"
+RRECOMMENDS = "tickypip-levels"
+PR = "r5"
+
+SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/tickypip-0.1.2.tar.gz \
+ file://path_fix.patch;patch=1 \
+ file://tickypip.desktop \
+ file://tickypip.png"
+
+APPNAME = "tickypip"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}"
+
+QMAKE_PROFILES = "tickypip.pro"
+EXTRA_QMAKEVARS_POST += "DEFINES-=LOCAL_COMPILE DEFINES+=DATA_BASEDIR='\"${palmtopdir}\"'"
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${S}/images/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+
+# copy share
+ install -d ${D}${palmtopdir}/share/${APPNAME}/levels
+ install -m 0644 ${S}/levels/* ${D}${palmtopdir}/share/${APPNAME}/levels/
+}
+
+
+inherit opie