aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorBrijesh Singh <bksingh@ti.com>2010-09-28 20:59:54 -0500
committerKoen Kooi <koen@openembedded.org>2010-09-30 13:20:25 +0200
commit4430b2a315371cdec3b5c07da45ca7d3bc04c603 (patch)
tree7ba26501cc873a52ff32ddb65c58e05d4f7f04f9 /recipes/ti
parenta26253b6567991a569b45ac762a5766ecb8763e4 (diff)
downloadopenembedded-4430b2a315371cdec3b5c07da45ca7d3bc04c603.tar.gz
ti-c6accel_1.01.00.01: add new c6accel version.
Signed-off-by: Brijesh Singh <bksingh@ti.com> Signed-off-by: Denys Dmytriyenko <denis@denix.org> Signed-off-by: Roger Monk <r-monk@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-c6accel.inc25
-rw-r--r--recipes/ti/ti-c6accel_1.01.00.01.bb10
2 files changed, 21 insertions, 14 deletions
diff --git a/recipes/ti/ti-c6accel.inc b/recipes/ti/ti-c6accel.inc
index c7f2243e3c..edac1cff23 100644
--- a/recipes/ti/ti-c6accel.inc
+++ b/recipes/ti/ti-c6accel.inc
@@ -16,9 +16,9 @@ COMPATIBLE_MACHINE = "(da850-omapl138-evm|omap3evm|dm37x-evm)"
PROVIDES += "ti-c6accel-apps"
-PR = "r8"
+PR = "r12"
-S = "${WORKDIR}/c6accel_${PV}/c6accel_${PV}"
+S = "${WORKDIR}/c6accel_${PV}"
SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/c6000/web/c6accel/latest/exports//c6accel_${PV}_Linux-x86_Setup.bin;name=c6accelbin "
@@ -30,9 +30,10 @@ DEPENDS += "ti-edma3lld ti-cgt6x ti-xdctools ti-framework-components"
DEPENDS += "ti-biosutils"
do_compile() {
+ unset VERBOSE
# Build C6Accel package
cd ${S}
- PLATFORM="${PLATFORM}" make \
+ make \
PLATFORM="${PLATFORM}" \
CE_INSTALL_DIR="${CE_INSTALL_DIR}" \
XDAIS_INSTALL_DIR="${XDAIS_INSTALL_DIR}" \
@@ -46,9 +47,9 @@ do_compile() {
BIOSUTILS_INSTALL_DIR="${BIOSUTILS_INSTALL_DIR}" \
LPM_INSTALL_DIR="${LPM_INSTALL_DIR}" \
SERVER_INSTALL_DIR="${CODEC_INSTALL_DIR}" \
- C6ACCEL_INSTALL_DIR="${S}/soc" \
+ C6ACCEL_INSTALL_DIR="${S}" \
CSTOOL_DIR="${TOOLCHAIN_PATH}" \
- CSTOOLS_PREFIX="${TOOLCHAIN_PATH}/bin/${TARGET_PREFIX}" \
+ CSTOOL_PREFIX="${TOOLCHAIN_PATH}/bin/${TARGET_PREFIX}" \
all
}
@@ -56,23 +57,19 @@ do_compile() {
do_install() {
install -d ${D}${C6ACCEL_INSTALL_DIR_RECIPE}
cp -pPrf ${S}/* ${D}${C6ACCEL_INSTALL_DIR_RECIPE}
-
+
+ # update linker.cmd file to point to sysroot
+ sed -i ${i} -e s=${S}=${C6ACCEL_INSTALL_DIR}=g ${D}${C6ACCEL_INSTALL_DIR_RECIPE}/soc/app/c6accel_app_config/linker.cmd
+
cd ${S}
make \
PLATFORM="${PLATFORM}" \
CMEM_INSTALL_DIR="${CMEM_INSTALL_DIR}" \
LINK_INSTALL_DIR="${LINK_INSTALL_DIR}" \
LPM_INSTALL_DIR="${LPM_INSTALL_DIR}" \
- C6ACCEL_INSTALL_DIR="${S}/soc" \
+ C6ACCEL_INSTALL_DIR="${S}" \
EXEC_DIR_C6ACCEL="${D}/${installdir}/c6accel-apps" \
install
-
- # replace insmod with modprobe
- sed -i 's/insmod/modprobe/g' ${D}/${installdir}/c6accel-apps/loadmodules_${PLATFORM}_c6accel.sh
- sed -i 's/.ko//g' ${D}/${installdir}/c6accel-apps/loadmodules_${PLATFORM}_c6accel.sh
- # remove prebuilt *.ko files
- rm -rf ${D}/${installdir}/c6accel-apps/*.ko
-
}
PACKAGES += "ti-c6accel-apps"
diff --git a/recipes/ti/ti-c6accel_1.01.00.01.bb b/recipes/ti/ti-c6accel_1.01.00.01.bb
new file mode 100644
index 0000000000..1a8561f2ee
--- /dev/null
+++ b/recipes/ti/ti-c6accel_1.01.00.01.bb
@@ -0,0 +1,10 @@
+require ti-c6accel.inc
+
+
+SRC_URI_append = "file://fix-loadmodule.patch"
+
+PV = "1_01_00_01"
+
+SRC_URI[c6accelbin.md5sum] = "b8d3b31bc14908e1946fecfd4596a8f1"
+SRC_URI[c6accelbin.sha256sum] = "5239dfd7a5a240ec66f4788ebca455dc7a961d83a4e08fe61c6af0eb79594f7c"
+