aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti/ti-sdma-module_2.24.01.bb
diff options
context:
space:
mode:
authorBrijesh Singh <bksingh@ti.com>2009-09-04 23:42:09 -0500
committerOpenEmbedded User <oe@OE-builder.(none)>2009-09-13 12:36:41 +0200
commit1cf11450bf8a5396cfda5ce758d12e167497a1c5 (patch)
treef7b9effa594510d928fa19de897ed74a455e74e8 /recipes/ti/ti-sdma-module_2.24.01.bb
parent462d0b6fb1ff920f0be3ffb72e5d58ee70d166fe (diff)
downloadopenembedded-1cf11450bf8a5396cfda5ce758d12e167497a1c5.tar.gz
lpm, sdma, cmem recipes: rename to match PV
Diffstat (limited to 'recipes/ti/ti-sdma-module_2.24.01.bb')
-rw-r--r--recipes/ti/ti-sdma-module_2.24.01.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/recipes/ti/ti-sdma-module_2.24.01.bb b/recipes/ti/ti-sdma-module_2.24.01.bb
new file mode 100644
index 0000000000..2d9b3a8df7
--- /dev/null
+++ b/recipes/ti/ti-sdma-module_2.24.01.bb
@@ -0,0 +1,54 @@
+DESCRIPTION = "SDMA module for TI OMAP3 processors"
+
+inherit module
+# compile and run time dependencies
+DEPENDS = "virtual/kernel perl-native"
+
+#This is a kernel module, don't set PR directly
+MACHINE_KERNEL_PR_append = "a"
+
+PV = "2241"
+
+SRC_URI = "http://install.source.dir.com/codec_engine_2_24_01.tar.gz "
+
+# Set the source directory
+S = "${WORKDIR}/codec_engine_2_24_01"
+
+do_compile() {
+ # SDMA - Build the sdma module
+ # TODO :: KERNEL_CC, etc need replacing with user CC
+ # TODO :: Need to understand why OBJDUMP is required for kernel module
+ # Unset these since LDFLAGS gets picked up and used incorrectly.... need
+ # investigation
+
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+
+ cd ${S}/cetools/packages/ti/sdo/linuxutils/sdma
+ make \
+ LINUXKERNEL_INSTALL_DIR="${STAGING_KERNEL_DIR}" \
+ MVTOOL_PREFIX="${TARGET_PREFIX}" \
+ UCTOOL_PREFIX="${TARGET_PREFIX}" \
+ clean debug release
+}
+
+do_install () {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
+ install -m 0755 ${S}/cetools/packages/ti/sdo/linuxutils/sdma/src/module/sdmak.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
+}
+
+pkg_postinst () {
+ if [ -n "$D" ]; then
+ exit 1
+ fi
+ depmod -a
+ update-modules || true
+}
+
+pkg_postrm () {
+ update-modules || true
+}
+
+INHIBIT_PACKAGE_STRIP = "1"
+
+FILES_${PN} = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/sdmak.ko"
+