aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti/ti-codecs-dm6467_1.0.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <[denis@denix.org]>2010-01-19 10:57:25 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:11 +0200
commitd340aed2722d402742b02b27ad6ba8eee6c791ed (patch)
tree70da5a9db95def049ae7a18393a83a7a357b24b3 /recipes/ti/ti-codecs-dm6467_1.0.0.bb
parentdc72be68dda9e67c81ab65d8f1cd1bda25e1bf76 (diff)
downloadopenembedded-d340aed2722d402742b02b27ad6ba8eee6c791ed.tar.gz
ti: add codecs for DM6467
Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti/ti-codecs-dm6467_1.0.0.bb')
-rw-r--r--recipes/ti/ti-codecs-dm6467_1.0.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/ti/ti-codecs-dm6467_1.0.0.bb b/recipes/ti/ti-codecs-dm6467_1.0.0.bb
new file mode 100644
index 0000000000..219d02f670
--- /dev/null
+++ b/recipes/ti/ti-codecs-dm6467_1.0.0.bb
@@ -0,0 +1,41 @@
+require ti-codec.inc
+
+PR = "r4"
+CSVER = "2"
+PV = "1_00_00"
+
+SRC_URI = "http://install.source.dir.local/cs${CSVER}dm6467_${PV}.tar.gz;name=dm6467codecs"
+
+SRC_URI[dm6467codecs.md5sum] = "43fc636eb037752169ba6ce9925a39d6"
+SRC_URI[dm6467codecs.sha256sum] = "06f3efc4fbdb205884ece90ebc02c0caa536e86012b1d09c95ba4786d24681c3"
+
+# Set the source directory
+S = "${WORKDIR}/cs${CSVER}dm6467_${PV}"
+
+# compile time dependencies
+DEPENDS="ti-codec-engine ti-biosutils ti-dsplink-module"
+
+do_compile() {
+ make CE_INSTALL_DIR=${CE_INSTALL_DIR} \
+ FC_INSTALL_DIR=${FC_INSTALL_DIR} \
+ EDMA3_LLD_INSTALL_DIR=${EDMA3_LLD_INSTALL_DIR} \
+ LINK_INSTALL_DIR=${LINK_INSTALL_DIR} \
+ CMEM_INSTALL_DIR=${CMEM_INSTALL_DIR} \
+ LPM_INSTALL_DIR=${LPM_INSTALL_DIR} \
+ BIOS_INSTALL_DIR=${BIOS_INSTALL_DIR} \
+ CODEGEN_INSTALL_DIR=${CODEGEN_INSTALL_DIR} \
+ XDC_INSTALL_DIR=${XDC_INSTALL_DIR} \
+ clean all
+
+}
+
+do_install () {
+ install -d ${D}/${installdir}/codec-combo
+ cd ${S}
+ for file in `find . -name *.x64P`; do
+ cp ${file} ${D}/${installdir}/codec-combo
+ done
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+INHIBIT_PACKAGE_STRIP = "1"