aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti/ti-codec-engine_2.25.00.05.bb
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2010-01-16 10:49:54 +0000
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:11 +0200
commitdc72be68dda9e67c81ab65d8f1cd1bda25e1bf76 (patch)
tree9aa7471c3112ab5ad998b7d2c5ee51966f1f56a8 /recipes/ti/ti-codec-engine_2.25.00.05.bb
parentb828469f5906a0f35896c521880db9cc3812fa26 (diff)
downloadopenembedded-dc72be68dda9e67c81ab65d8f1cd1bda25e1bf76.tar.gz
ti-codec-engine: Move version specific code into versioned part + add devices
Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti/ti-codec-engine_2.25.00.05.bb')
-rw-r--r--recipes/ti/ti-codec-engine_2.25.00.05.bb30
1 files changed, 25 insertions, 5 deletions
diff --git a/recipes/ti/ti-codec-engine_2.25.00.05.bb b/recipes/ti/ti-codec-engine_2.25.00.05.bb
index 6e67fd5b75..e903df359c 100644
--- a/recipes/ti/ti-codec-engine_2.25.00.05.bb
+++ b/recipes/ti/ti-codec-engine_2.25.00.05.bb
@@ -1,10 +1,5 @@
require ti-codec-engine.inc
-DEFAULT_PREFERENCE = "-1"
-DEFAULT_PREFERENCE_omapl138 = "1"
-
-
-# tconf from xdctools dislikes '.' in pwd :/
PV = "2_25_00_05"
# Full-CE
@@ -15,6 +10,31 @@ PV = "2_25_00_05"
SRC_URI[cetarball.md5sum] = "618f027c4a471a0658ed999621ac190b"
SRC_URI[cetarball.sha256sum] = "81acdf9236f3062c26356db502837ae13addb35f03c02a847f9b0face9657b51"
+do_compile_prepend() {
+
+ # Add OMAPL138 target build configuration
+ sed -i \
+ -e 's/# figure out what categories of devices we are to build for/ \
+# figure out what categories of devices we are to build for \
+ifneq (,$(findstring OMAPL138,$(DEVICES))) \
+ DEVICES_DUALCPU := 1 \
+endif/g' \
+ ${S}/examples/xdcpaths.mak
+
+}
+
do_install_prepend() {
+
+ # Re-use OMAPL137 system files for OMAPL138
ln -sf ${S}/examples/apps/system_files/OMAPL137 ${S}/examples/apps/system_files/OMAPL138 || true
}
+
+do_install_append() {
+
+ # Fix-up loadmodules to use modprobe instead of insmod
+ sed -i \
+ -e 's/insmod/modprobe/g' \
+ -e 's/.ko//g' \
+ ${D}/${installdir}/codec-engine-apps/loadmodules.sh
+}
+