aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti/ti-codec-engine_2.24.01.bb
diff options
context:
space:
mode:
authorSebastian Spaeth <Sebastian@SSpaeth.de>2009-12-17 13:47:50 +0100
committerSebastian Spaeth <Sebastian@SSpaeth.de>2009-12-17 13:47:50 +0100
commitf45580a1527dccdda100eee7f25f9f2c41af4db8 (patch)
tree2218d4955f368e1804d86f212cc78317b4327f77 /recipes/ti/ti-codec-engine_2.24.01.bb
parent887b437869709625f5323438808ded9990cf590a (diff)
parente3df24d64a48aff19aa9960dd9308a071b243b09 (diff)
downloadopenembedded-f45580a1527dccdda100eee7f25f9f2c41af4db8.tar.gz
Merge commit 'origin/shr/merge' into shr/testing2009
Conflicts: conf/distro/include/sane-srcrevs.inc recipes/enotes/enotes_svn.bb recipes/intone-video/intone-video_svn.bb recipes/intone/intone_svn.bb recipes/shr/shr-wizard_git.bb recipes/tasks/task-shr-minimal.bb Signed-off-by: Sebastian Spaeth <Sebastian@SSpaeth.de>
Diffstat (limited to 'recipes/ti/ti-codec-engine_2.24.01.bb')
-rw-r--r--recipes/ti/ti-codec-engine_2.24.01.bb66
1 files changed, 32 insertions, 34 deletions
diff --git a/recipes/ti/ti-codec-engine_2.24.01.bb b/recipes/ti/ti-codec-engine_2.24.01.bb
index 9be02046a4..ae0197e3d2 100644
--- a/recipes/ti/ti-codec-engine_2.24.01.bb
+++ b/recipes/ti/ti-codec-engine_2.24.01.bb
@@ -3,14 +3,14 @@ DESCRIPTION = "Codec Engine 2.24.01 for TI ARM/DSP processors"
require ti-paths.inc
# compile time dependencies
-DEPENDS = "ti-xdctools-native"
+DEPENDS = "ti-framework-components ti-xdais-native ti-xdctools-native ti-cgt6x-native"
-DEPENDS_append_dm6446-evm = " ti-cgt6x-native ti-dspbios-native ti-dsplink-module"
-DEPENDS_append_armv7a = " ti-cgt6x-native ti-dspbios-native ti-dsplink-module"
+DEPENDS_append_dm6446 = " ti-dspbios-native ti-linuxutils ti-dsplink-module"
+DEPENDS_append_omap3 = " ti-dspbios-native ti-linuxutils ti-dsplink-module"
# tconf from xdctools dislikes '.' in pwd :/
PR = "r7"
-PV = "2241"
+PV = "2_24_01"
SRC_URI = "http://install.source.dir.local/codec_engine_2_24_01.tar.gz "
@@ -18,19 +18,18 @@ SRC_URI = "http://install.source.dir.local/codec_engine_2_24_01.tar.gz "
S = "${WORKDIR}/codec_engine_2_24_01"
# Define Device variable
-DEVICES_dm6446-evm ?= "DM6446"
-
-# define gppos variable
-GPPOS_dm6446-evm ?= "LINUX_GCC"
+DEVICES_dm6446 ?= "DM6446"
+DEVICES_omap3 ?= "OMAP3530"
+DEVICES_dm355 ?= "DM355"
#define PROGRAM variables
-PROGRAMS = "APP_CLIENT DSP_SERVER"
+PROGRAMS ?= "APP_CLIENT DSP_SERVER"
+PROGRAMS_dm355 = "APP_LOCAL"
LINK_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-dsplink-module/packages"
-DSPBIOS_DIR="${STAGING_DIR_NATIVE}/ti-dspbios-native"
-CGT6x_DIR="${STAGING_DIR_NATIVE}/ti-cgt6x-native"
-XDCTOOLS_DIR="${STAGING_DIR_NATIVE}/ti-xdctools-native"
-CE_INSTALL_DIR="${S}"
+CGT6x_DIR = "${STAGING_DIR_NATIVE}/ti-cgt6x-native"
+XDCTOOLS_DIR = "${STAGING_DIR_NATIVE}/ti-xdctools-native"
+CE_INSTALL_DIR = "${S}"
do_compile () {
@@ -38,35 +37,34 @@ do_compile () {
-e s:arm-none-linux-gnueabi-:${TARGET_PREFIX}:g \
${S}/examples/xdcpaths.mak
- for i in codecs extensions servers apps ; do
- cd ${S}/examples/ti/sdo/ce/examples/$i
- make DEVICES="${DEVICES}" \
- GPPOS="${GPPOS}" \
- PROGRAMS="${PROGRAMS}" \
- CE_INSTALL_DIR="${CE_INSTALL_DIR}" \
- XDC_INSTALL_DIR="${XDCTOOLS_DIR}" \
- BIOS_INSTALL_DIR="${DSPBIOS_DIR}"\
- DSPLINK_INSTALL_DIR="${LINK_INSTALL_DIR}" \
- XDAIS_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
- FC_INSTALL_DIR="${FC_INSTALL_DIR}" \
- CMEM_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
- LPM_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
- EDMA3_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
- FC_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
- CGTOOLS_V5T="${CROSS_DIR}"\
- CGTOOLS_C64P="${CGT6x_DIR}" \
- clean all
- done
+ for i in codecs extensions servers apps ; do
+ cd ${S}/examples/ti/sdo/ce/examples/$i
+ make DEVICES="${DEVICES}" \
+ GPPOS="${GPPOS}" \
+ PROGRAMS="${PROGRAMS}" \
+ CE_INSTALL_DIR="${CE_INSTALL_DIR}" \
+ XDC_INSTALL_DIR="${XDCTOOLS_DIR}" \
+ BIOS_INSTALL_DIR="${BIOS_INSTALL_DIR}"\
+ DSPLINK_INSTALL_DIR="${LINK_INSTALL_DIR}" \
+ XDAIS_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
+ FC_INSTALL_DIR="${FC_INSTALL_DIR}" \
+ CMEM_INSTALL_DIR="${CMEM_INSTALL_DIR}" \
+ LPM_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
+ EDMA3_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
+ CGTOOLS_V5T="${CROSS_DIR}"\
+ CGTOOLS_C64P="${CGT6x_DIR}" \
+ clean all
+ done
}
do_install() {
install -d ${D}/${installdir}/codec-engine-apps
- cp ${S}/examples/apps/system_files/${DEVICES}/loadmodules.sh ${D}/${installdir}/codec-engine-apps
+ cp ${S}/examples/apps/system_files/${DEVICES}/loadmodules.sh ${D}/${installdir}/codec-engine-apps
sed -i 's/insmod/modprobe/g' ${D}/${installdir}/codec-engine-apps/loadmodules.sh
cd ${S}/examples/ti/sdo/ce/examples
- for i in $(find . -name "*.xv5T"); do
+ for i in $(find . -name "*.xv5T"); do
install -d ${D}/${installdir}/codec-engine-apps/`dirname ${i} | cut -f3 -d /`
install ${i} ${D}/${installdir}/codec-engine-apps/`dirname ${i} | cut -f3 -d /`