summaryrefslogtreecommitdiffstats
path: root/recipes/tasks/task-boot.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tasks/task-boot.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tasks/task-boot.bb')
-rw-r--r--recipes/tasks/task-boot.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/tasks/task-boot.bb b/recipes/tasks/task-boot.bb
new file mode 100644
index 0000000000..1a1b9f25c8
--- /dev/null
+++ b/recipes/tasks/task-boot.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Basic task to get a device booting"
+PR = "r49"
+
+inherit task
+
+# packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH
+#
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+#
+# those ones can be set in machine config to supply packages needed to get machine booting
+#
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
+
+# Make sure we build the kernel
+DEPENDS = "virtual/kernel"
+
+#
+# minimal set of packages - needed to boot
+#
+RDEPENDS_task-boot = "\
+ kernel \
+ base-files \
+ base-passwd \
+ busybox \
+ ${@base_contains("MACHINE_FEATURES", "keyboard", "keymaps", "", d)} \
+ modutils-initscripts \
+ netbase \
+ update-alternatives \
+ ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
+ "
+
+RRECOMMENDS_task-boot = "\
+ ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS} \
+ "