aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/syslinux/syslinux_3.63.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/syslinux/syslinux_3.63.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/syslinux/syslinux_3.63.bb')
-rw-r--r--recipes/syslinux/syslinux_3.63.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/syslinux/syslinux_3.63.bb b/recipes/syslinux/syslinux_3.63.bb
new file mode 100644
index 0000000000..95fb55708a
--- /dev/null
+++ b/recipes/syslinux/syslinux_3.63.bb
@@ -0,0 +1,32 @@
+# syslinux OE build file
+# Copyright (C) 2009, O.S. Systems Software Ltda. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="A multi-purpose linux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+LICENSE="GPL"
+DEPENDS="nasm-native"
+RDEPENDS="mtools"
+PR="r2"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
+
+S="${WORKDIR}/syslinux-${PV}"
+
+inherit autotools
+
+do_configure_prepend() {
+ # drop win32 targets or build fails
+ sed -i 's,win32/\S*,,g' -i Makefile
+}
+
+do_compile() {
+ oe_runmake CC="${CC}"
+}
+
+do_install() {
+ oe_runmake install INSTALLROOT="${D}"
+
+ # we don't use com32, drop it
+ rm -r "${D}/${libdir}/syslinux/com32"
+}