summaryrefslogtreecommitdiffstats
path: root/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb
diff options
context:
space:
mode:
authorMartyn Welch <martyn.welch@ge.com>2010-03-21 23:34:53 +0000
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-03-30 14:14:29 +0200
commitba9d4c218163404167cde22fafbf362a2f128191 (patch)
tree1158927276edf2d2b1447c4c7e7f08f4e3d7a2b5 /recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb
parent7d7f2596ec0aea7684d2c05fa852f093b622b530 (diff)
downloadopenembedded-ba9d4c218163404167cde22fafbf362a2f128191.tar.gz
start-stop-daemon: added standalone C version
This is not needed if you are building with busybox, however it is required if attempting a busybox-less build and do not want to have DPKG installed. Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb')
-rw-r--r--recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb b/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb
new file mode 100644
index 0000000000..1591b09aba
--- /dev/null
+++ b/recipes/start-stop-daemon/start-stop-daemon_1.9.18.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Debian's start-stop-daemon utility"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "PD"
+PR = "r0"
+
+SRC_URI = "file://start-stop-daemon.c"
+
+S = "${WORKDIR}"
+
+do_configure() {
+ :
+}
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/start-stop-daemon.c -o start-stop-daemon
+}
+
+do_install () {
+ install -d ${D}/${base_sbindir}
+ install -m 0755 ${S}/start-stop-daemon ${D}/${base_sbindir}/start-stop-daemon
+}