aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sparse/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/sparse/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/sparse/files')
-rw-r--r--recipes/sparse/files/compile.patch16
-rw-r--r--recipes/sparse/files/vars.patch42
2 files changed, 58 insertions, 0 deletions
diff --git a/recipes/sparse/files/compile.patch b/recipes/sparse/files/compile.patch
new file mode 100644
index 0000000000..f19d521335
--- /dev/null
+++ b/recipes/sparse/files/compile.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- sparse-bk/expression.c~compile 2004-09-13 17:42:22.642639000 -0400
++++ sparse-bk/expression.c 2004-09-13 17:44:59.147847520 -0400
+@@ -8,7 +8,7 @@
+ *
+ * This is the expression parsing part of parsing C.
+ */
+-#define _ISOC99_SOURCE
++//#define _ISOC99_SOURCE
+ #include <stdarg.h>
+ #include <stdlib.h>
+ #include <stdio.h>
diff --git a/recipes/sparse/files/vars.patch b/recipes/sparse/files/vars.patch
new file mode 100644
index 0000000000..353df2ad0b
--- /dev/null
+++ b/recipes/sparse/files/vars.patch
@@ -0,0 +1,42 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- sparse-bk/Makefile~vars 2004-09-13 17:45:43.304134000 -0400
++++ sparse-bk/Makefile 2004-09-13 17:46:04.980839384 -0400
+@@ -1,4 +1,5 @@
+ CC=gcc
++CCLD=gcc
+ CFLAGS=-O -g -Wall
+ LDFLAGS=-g
+ AR=ar
+@@ -26,22 +27,22 @@
+ if test $< -nt $(PREFIX)/bin/sparse ; then install -v $< $(PREFIX)/bin/sparse ; fi
+
+ test-lexing: test-lexing.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ test-parsing: test-parsing.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ test-linearize: test-linearize.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ compile: compile.o compile-i386.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< compile-i386.o $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< compile-i386.o $(LIBS)
+
+ obfuscate: obfuscate.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ check: check.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ $(LIB_FILE): $(LIB_OBJS)
+ $(AR) rcs $(LIB_FILE) $(LIB_OBJS)