aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-03-19 15:07:02 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-03-19 15:07:02 +0100
commitb6eeb76bca7014199300425b239f01fbe58000bf (patch)
tree7f94e9702423977e25db21fd10a49c73c89198d9 /recipes/shr
parentf19b78a3176ed2086ffe9d3eccfb667981f75e0b (diff)
parent1405e1aabefc6ea1c47c931a18dc945f5b9a4855 (diff)
downloadopenembedded-b6eeb76bca7014199300425b239f01fbe58000bf.tar.gz
Merge remote branch 'origin/org.openembedded.dev' into shr/unstable
Conflicts: recipes/xorg-lib/pixman_git.bb
Diffstat (limited to 'recipes/shr')
-rw-r--r--recipes/shr/elementary-theme-o2_git.bb27
-rw-r--r--recipes/shr/phoneui-shr-theme-o2_git.bb27
-rw-r--r--recipes/shr/shr-theme-o2.bb10
3 files changed, 64 insertions, 0 deletions
diff --git a/recipes/shr/elementary-theme-o2_git.bb b/recipes/shr/elementary-theme-o2_git.bb
new file mode 100644
index 0000000000..54a7f81538
--- /dev/null
+++ b/recipes/shr/elementary-theme-o2_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "o2 theme for the elementary toolkit - it looks like om2007.2"
+SECTION = "e/utils"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+DEPENDS = "edje-native"
+RSUGGESTS = "phoneui-shr-theme-o2"
+LICENSE = "unknown"
+
+SRCREV = "b5eb3134850c277ad8ae1a960b03ff4a509278a8"
+PV = "0.1-${EFL_SRCREV}+gitr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master \
+ "
+
+S = "${WORKDIR}/git/elementary/${PN}"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/. -fd ${S}/. ${S}/o2.edc -o ${S}/o2.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/elementary/themes/
+ install -m 0644 ${S}/o2.edj ${D}${datadir}/elementary/themes/
+}
+
+FILES_${PN} = "${datadir}/elementary/themes/"
diff --git a/recipes/shr/phoneui-shr-theme-o2_git.bb b/recipes/shr/phoneui-shr-theme-o2_git.bb
new file mode 100644
index 0000000000..51c6f62ba0
--- /dev/null
+++ b/recipes/shr/phoneui-shr-theme-o2_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "o2 theme for libphone-ui-shr - it looks like om2007.2"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+SECTION = "e/utils"
+LICENSE = "unknown"
+DEPENDS = "edje-native"
+RDEPENDS = "libphone-ui-shr"
+RSUGGESTS = "elementary-theme-o2"
+SRCREV = "b5eb3134850c277ad8ae1a960b03ff4a509278a8"
+PV = "0.1+gitr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/phoneui-shr/${PN}"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/. -fd ${S}/. ${S}/o2.edc -o ${S}/o2.edj
+}
+do_install() {
+ install -d ${D}${datadir}/libphone-ui-shr/
+ install -m 0644 ${S}/o2.edj ${D}${datadir}/libphone-ui-shr/
+ install -m 0644 ${S}/config ${D}${datadir}/libphone-ui-shr/
+}
+
+FILES_${PN} = "${datadir}/libphone-ui-shr/"
+CONFFILES_${PN} = "${datadir}/libphone-ui-shr/config"
diff --git a/recipes/shr/shr-theme-o2.bb b/recipes/shr/shr-theme-o2.bb
new file mode 100644
index 0000000000..6c03d12982
--- /dev/null
+++ b/recipes/shr/shr-theme-o2.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "o2 theme suit for shr - it looks like om2007.2"
+SECTION = "x11/data"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+RDEPENDS = "phoneui-shr-theme-o2 elementary-theme-o2"
+LICENSE = "unknown"
+
+PV = "0.1"
+
+ALLOW_EMPTY = "1"