aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr/shr-specs_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-15 19:29:48 +0100
committerKlaus Kurzmann <mok@fluxnetz.de>2009-11-15 19:56:34 +0100
commitf18414059f60ec5924a702a227069aac09f19a0b (patch)
tree965f002fa3fdc5ad9fbb4715dd92e093110e2562 /recipes/shr/shr-specs_git.bb
parent52b9d26f27203c9df18fa4f4855cb006af800c0b (diff)
downloadopenembedded-f18414059f60ec5924a702a227069aac09f19a0b.tar.gz
shr phone applications: new recipes
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes/shr/shr-specs_git.bb')
-rw-r--r--recipes/shr/shr-specs_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/shr/shr-specs_git.bb b/recipes/shr/shr-specs_git.bb
new file mode 100644
index 0000000000..bc29ee5e27
--- /dev/null
+++ b/recipes/shr/shr-specs_git.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "The SHR DBus API Specification"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "BSD"
+SECTION = "devel/specifications"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-specs.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+do_compile() {
+ make xml
+}
+
+do_stage() {
+ install -d "${STAGING_DATADIR}/shr-specs"
+ install -m 0644 xml/* "${STAGING_DATADIR}/shr-specs"
+}
+
+FILE_${PN}-dev += "${datadir}/shr-specs"
+
+