aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr/phonefsod_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-15 19:29:48 +0100
committerKlaus Kurzmann <mok@fluxnetz.de>2009-11-15 19:56:34 +0100
commitf18414059f60ec5924a702a227069aac09f19a0b (patch)
tree965f002fa3fdc5ad9fbb4715dd92e093110e2562 /recipes/shr/phonefsod_git.bb
parent52b9d26f27203c9df18fa4f4855cb006af800c0b (diff)
downloadopenembedded-f18414059f60ec5924a702a227069aac09f19a0b.tar.gz
shr phone applications: new recipes
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes/shr/phonefsod_git.bb')
-rw-r--r--recipes/shr/phonefsod_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/shr/phonefsod_git.bb b/recipes/shr/phonefsod_git.bb
new file mode 100644
index 0000000000..bc443a11a5
--- /dev/null
+++ b/recipes/shr/phonefsod_git.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "SHR Phone FSO Daemon"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "x11/applications"
+DEPENDS += " dbus-glib libframeworkd-glib sqlite3 shr-specs"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "r2"
+
+SRC_URI = "git://git.shr-project.org/repo/phonefsod.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "phonefsod"
+INITSCRIPT_PARAMS = "defaults 75"
+
+EXTRA_OECONF = "\
+ SPECS_PATH=${STAGING_DATADIR}/shr-specs \
+"
+
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/dbus-1/system.d/
+ install -m 0755 ${S}/data/phonefsod.init ${D}${sysconfdir}/init.d/phonefsod
+ install -m 0644 ${S}/data/phonefsod.conf ${D}${sysconfdir}/dbus-1/system.d/
+ install -m 0644 ${S}/data/etc-phonefsod.conf ${D}${sysconfdir}/phonefsod.conf
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"
+