aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qt4/qt4-embedded_4.4.3.bb
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-03-25 17:00:59 +0100
committerJeremy Lainé <jeremy.laine@m4x.org>2009-03-25 17:00:59 +0100
commitac41ae95b1dbe54c05adf494c0fa44b3abbfeca3 (patch)
treea34220ed25168022c53d9cb5697f3666a427b30c /recipes/qt4/qt4-embedded_4.4.3.bb
parent82b9cae9c7298e430843f6d547abfaf9ff26eed0 (diff)
downloadopenembedded-ac41ae95b1dbe54c05adf494c0fa44b3abbfeca3.tar.gz
qt4: consolidate include files into qt4.inc
Diffstat (limited to 'recipes/qt4/qt4-embedded_4.4.3.bb')
-rw-r--r--recipes/qt4/qt4-embedded_4.4.3.bb40
1 files changed, 38 insertions, 2 deletions
diff --git a/recipes/qt4/qt4-embedded_4.4.3.bb b/recipes/qt4/qt4-embedded_4.4.3.bb
index a0bae7262b..015b48e597 100644
--- a/recipes/qt4/qt4-embedded_4.4.3.bb
+++ b/recipes/qt4/qt4-embedded_4.4.3.bb
@@ -1,2 +1,38 @@
-require qt4-embedded.inc
-PR = "r8"
+SUMMARY = "Qt is a versatile cross-platform application framework -- this is the embedded version."
+SECTION = "libs"
+LICENSE = "GPL"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.trolltech.com"
+DEPENDS += "tslib"
+PR = "r9"
+
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
+ file://0001-cross-compile.patch;patch=1 \
+ file://0002-fix-resinit-declaration.patch;patch=1 \
+ file://0003-no-tools.patch;patch=1 \
+ file://0004-no-qmake.patch;patch=1 \
+ file://0005-fix-mkspecs.patch;patch=1 \
+ file://0006-freetype-host-includes.patch;patch=1 \
+ file://0007-openssl-host-includes.patch;patch=1 \
+ file://0008-qt-lib-infix.patch;patch=1 \
+ file://0009-support-2bpp.patch;patch=1 \
+ "
+S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
+
+QT_CONFIG_FLAGS += " \
+ -qtlibinfix E \
+ -qt-decoration-styled -plugin-decoration-default -plugin-decoration-windows \
+ -plugin-gfx-transformed -plugin-gfx-qvfb -plugin-gfx-vnc \
+ -plugin-mouse-tslib -qt-mouse-pc -qt-mouse-qvfb \
+ -qt-kbd-tty -qt-kbd-usb -qt-kbd-qvfb \
+ -DQT_KEYPAD_NAVIGATION \
+ "
+
+QT_BASE_NAME = "qt-embedded"
+QT_BASE_LIB = "libqt-embedded"
+QT_DIR_NAME = "qtopia"
+QT_LIBINFIX="E"
+
+require qt4.inc
+
+inherit qt4e