aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qpe-gaim/qpe-gaim_20041030.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/qpe-gaim/qpe-gaim_20041030.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/qpe-gaim/qpe-gaim_20041030.bb')
-rw-r--r--recipes/qpe-gaim/qpe-gaim_20041030.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/qpe-gaim/qpe-gaim_20041030.bb b/recipes/qpe-gaim/qpe-gaim_20041030.bb
new file mode 100644
index 0000000000..f8f4d6a28f
--- /dev/null
+++ b/recipes/qpe-gaim/qpe-gaim_20041030.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "A multi protocol instant messager application, Qt/Embedded based Palmtop Environments Edition"
+SECTION = "opie/applications"
+DEPENDS = "qpe-libgaim glib-2.0"
+RDEPENDS = "libgaim-plugins glibc-gconv-iso8859-1"
+LICENSE = "GPL"
+HOMEPAGE = "http://qpe-gaim.sourceforge.net/"
+APPNAME = "gaim"
+APPTYPE = "binary"
+LICENSE = "GPL"
+APPDESKTOP = "${S}"
+PR = "r2"
+
+SRC_URI = "http://www.vanille.de/mirror/qpe-gaim_20041030.tar.bz2 \
+ file://qpe-gaim.patch;patch=1 \
+ file://buzzer-notification.patch;patch=1;pnum=1 \
+ file://vit.patch;patch=1"
+S = "${WORKDIR}/qpe-gaim"
+
+inherit opie
+
+EXTRA_QMAKEVARS_POST +="INCLUDEPATH-=${includedir}/glib-2.0 \
+ INCLUDEPATH-=${libdir}/glib-2.0/include \
+ INCLUDEPATH+=${STAGING_INCDIR}/glib-2.0 \
+ LIBS-=-lopie LIBS+=-lopiecore2 LIBS+=-lopieui2"
+
+do_configure_prepend() {
+ ln -s ../libgaim/src libgaim
+}
+
+do_install() {
+ for dir in 16x16 32x32 protocols status
+ do
+ install -d ${D}${palmtopdir}/pics/gaim/${dir}
+ install -m 0644 data/images/${dir}/*.png ${D}${palmtopdir}/pics/gaim/${dir}/
+ done
+ install -m 0644 gaim.png ${D}${palmtopdir}/pics/
+}