aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qemu/qemu_0.12.4.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-05-16 00:52:07 -0700
committerKhem Raj <raj.khem@gmail.com>2010-05-17 00:11:35 -0700
commit15f7ad62121a4f8b1fee2c9d258edcfd569afb8b (patch)
tree3718b147b79b9575fd5374a670971b9ccbc9f7e6 /recipes/qemu/qemu_0.12.4.bb
parent22c1f6069822fe6d32619ca54391777d7ed44126 (diff)
downloadopenembedded-15f7ad62121a4f8b1fee2c9d258edcfd569afb8b.tar.gz
qemu-0.12.4: Add recipes for 0.12.4
* Tested by booting arm, ppc, mips, sh4, and x86 systems Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/qemu/qemu_0.12.4.bb')
-rw-r--r--recipes/qemu/qemu_0.12.4.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes/qemu/qemu_0.12.4.bb b/recipes/qemu/qemu_0.12.4.bb
new file mode 100644
index 0000000000..05eb4c871e
--- /dev/null
+++ b/recipes/qemu/qemu_0.12.4.bb
@@ -0,0 +1,39 @@
+LICENSE = "GPL"
+DEPENDS = "zlib"
+
+PR = "r0"
+
+SRC_URI = "\
+ http://download.savannah.gnu.org/releases/qemu/qemu-${PV}.tar.gz;name=qemu-${PV} \
+ file://02_kfreebsd.patch;patch=1 \
+ file://03_support_pselect_in_linux_user_arm.patch;patch=1 \
+ file://05_bochs_vbe.diff;patch=1 \
+ file://06_sh4.diff;patch=1 \
+ file://leftover.patch;patch=1 \
+ file://3f26c1227e3b08010f2a65379cecf4cb4b5933fa.patch;patch=1 \
+ file://c5883be23519921254c6940873ee8db04979c20a.patch;patch=1 \
+ file://91-oh-sdl-cursor.patch;patch=1 \
+ file://fix_baum_c_compilation.patch;patch=1 \
+ file://fix_fortify_source_compilation.patch;patch=1 \
+ file://fallback.to.safe.mmap_min_addr.patch;patch=1 \
+ "
+
+SRC_URI[qemu-0.12.4.md5sum] = "93e6b134dff89b2799f57b7d9e0e0fc5"
+SRC_URI[qemu-0.12.4.sha256sum] = "1a29a5b5151162d1de035c4926d1a1dbffee4a145ef61ee865d6b82aaea0602e"
+
+BBCLASSEXTEND="native"
+
+S = "${WORKDIR}/qemu-${PV}"
+
+EXTRA_OECONF += " --disable-curl --disable-sdl --disable-strip \
+ "
+
+inherit autotools
+
+do_configure_prepend_virtclass-native() {
+ export QEMU_CFLAGS="-I${STAGING_INCDIR_NATIVE} ${QEMU_CFLAGS}"
+}
+
+do_configure() {
+ ${S}/configure --prefix=${prefix} ${EXTRA_OECONF}
+}