aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-02-23 11:59:04 -0700
committerTom Rini <tom_rini@mentor.com>2010-02-23 11:59:04 -0700
commit8fe1beae6d7bf91839c9c20327052ec68f3ae790 (patch)
treecfa73589f71767ba2af97432a2912e5255733877 /recipes/python
parent072cad0100fd828e7fee8f3fa3ade23e4306b394 (diff)
downloadopenembedded-8fe1beae6d7bf91839c9c20327052ec68f3ae790.tar.gz
python-pysqlite2-native: New recipe
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-pysqlite2-native_2.4.0.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes/python/python-pysqlite2-native_2.4.0.bb b/recipes/python/python-pysqlite2-native_2.4.0.bb
new file mode 100644
index 0000000000..0a7d667dca
--- /dev/null
+++ b/recipes/python/python-pysqlite2-native_2.4.0.bb
@@ -0,0 +1,10 @@
+require python-pysqlite2_${PV}.bb
+inherit native
+DEPENDS = "python-native sqlite3-native"
+RDEPENDS = ""
+
+do_stage() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
+ ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_BINDIR}/.. --install-data=${STAGING_DATADIR}
+}