aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorChristian Charreyre <christian.charreyre@cioinfoindus.fr>2011-04-29 17:43:58 +0200
committerPaul Menzel <paulepanter@users.sourceforge.net>2011-05-18 01:04:53 +0200
commit562661512f456e27870f1d5a3aace88915b3604c (patch)
tree2f4390f1e0f1bc6d10fed8b89ae021d7ce0022b7 /recipes/python
parent2a1c9e1ee5eb8067592d26100b563dd2ae7be00d (diff)
downloadopenembedded-562661512f456e27870f1d5a3aace88915b3604c.tar.gz
python-numpy: add missing runtime dependencies
Without these runtime dependencies there are errors on the target when executing `mypaint`, because `python-numpy` code calls `import` from the distinct packages. TODO: It is not clear where this error originates from and what the best fix is. There are the following alternatives. 1. Add the runtime dependencies to `mypaint`. 2. Add these packages to `RRECOMMENDS`. This patch is build tested using `angstrom-2010.x` for `MACHINE = "beagleboard"`. Signed-off-by: Christian Charreyre <christian.charreyre@cioinfoindus.fr> Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-numpy_1.1.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes/python/python-numpy_1.1.1.bb b/recipes/python/python-numpy_1.1.1.bb
index f5c23e055f..8594ea00b5 100644
--- a/recipes/python/python-numpy_1.1.1.bb
+++ b/recipes/python/python-numpy_1.1.1.bb
@@ -4,6 +4,8 @@ PRIORITY = "optional"
LICENSE = "PSF"
PR = "ml0"
+RDEPENDS_${PN} = "python-compiler python-mmap python-pkgutil python-pydoc python-unittest"
+
SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
file://unbreak-assumptions.diff \
file://trycompile.diff \