aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-native-2.6.4/00-fix-bindir-libdir-for-cross.patch
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2010-01-28 12:51:22 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-02-01 18:44:27 +0100
commit4d0023adf6b1f76028b40d9edf313f94c831cc90 (patch)
tree9b44090ee68f6a88a8c8e3b1e84c09a44a74287e /recipes/python/python-native-2.6.4/00-fix-bindir-libdir-for-cross.patch
parent506f7841f89c8cd735fdc864c3da8d9601f9ca08 (diff)
downloadopenembedded-4d0023adf6b1f76028b40d9edf313f94c831cc90.tar.gz
python: add version 2.6.4
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Michael 'Mickey' Lauer <mickey@vanille-media.de>
Diffstat (limited to 'recipes/python/python-native-2.6.4/00-fix-bindir-libdir-for-cross.patch')
-rw-r--r--recipes/python/python-native-2.6.4/00-fix-bindir-libdir-for-cross.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/python/python-native-2.6.4/00-fix-bindir-libdir-for-cross.patch b/recipes/python/python-native-2.6.4/00-fix-bindir-libdir-for-cross.patch
new file mode 100644
index 0000000000..2559e3a0e4
--- /dev/null
+++ b/recipes/python/python-native-2.6.4/00-fix-bindir-libdir-for-cross.patch
@@ -0,0 +1,20 @@
+# $(exec_prefix) points to the wrong directory, when installing
+# a cross-build. @bindir@ and @libdir@ works better and doesn't
+# affect the native build.
+# Signed-Off: Michael 'Mickey' Lauer <mickey@vanille-media.de>
+
+Index: Python-2.6.1/Makefile.pre.in
+===================================================================
+--- Python-2.6.1.orig/Makefile.pre.in
++++ Python-2.6.1/Makefile.pre.in
+@@ -86,8 +86,8 @@ exec_prefix= @exec_prefix@
+ datarootdir= @datarootdir@
+
+ # Expanded directories
+-BINDIR= $(exec_prefix)/bin
+-LIBDIR= $(exec_prefix)/lib
++BINDIR= @bindir@
++LIBDIR= @libdir@
+ MANDIR= @mandir@
+ INCLUDEDIR= @includedir@
+ CONFINCLUDEDIR= $(exec_prefix)/include