aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pulseaudio/libcanberra_0.12.bb
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-04-18 12:17:03 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-04-18 12:17:03 +0000
commit279420fa8c2589fdda8184ff391a613a567f0245 (patch)
tree485055adb736235009de016d29d692b1ffcfaf5e /recipes/pulseaudio/libcanberra_0.12.bb
parent523f0e2302d505cbf1ab1f598a41fe094fda76ba (diff)
downloadopenembedded-279420fa8c2589fdda8184ff391a613a567f0245.tar.gz
libcanberra: Updated to version 0.12.
Diffstat (limited to 'recipes/pulseaudio/libcanberra_0.12.bb')
-rw-r--r--recipes/pulseaudio/libcanberra_0.12.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/pulseaudio/libcanberra_0.12.bb b/recipes/pulseaudio/libcanberra_0.12.bb
new file mode 100644
index 0000000000..42fc3c68a8
--- /dev/null
+++ b/recipes/pulseaudio/libcanberra_0.12.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Libcanberra is an implementation of the XDG Sound Theme and Name Specifications, for generating event sounds on free desktops."
+LICENSE = "LGPL"
+DEPENDS = "gtk+ pulseaudio alsa-lib"
+
+inherit gconf autotools
+
+SRC_URI = "http://0pointer.de/lennart/projects/libcanberra/libcanberra-${PV}.tar.gz"
+
+EXTRA_OECONF = " --disable-oss "
+# This needs autoconf 2.62, which isn't used by any distro in OE atm
+do_configure() {
+ gnu-configize --force
+ oe_runconf
+}
+
+FILES_${PN} += "${libdir}/gtk-2.0/modules/ ${datadir}/gnome"
+FILES_${PN}-dbg += "${libdir}/gtk-2.0/modules/.debug"
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}