aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/portmap/portmap-6.0
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2009-08-10 04:49:55 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-08-10 06:49:53 +0200
commit4fe22eed50ce7c45da30b0efc6106b90281ff5f5 (patch)
tree2cdb26a07868492c136fe014c9e7ed35d083981f /recipes/portmap/portmap-6.0
parentf20d7d2a7e87b6c9fa8f368cce8813188c80f00c (diff)
downloadopenembedded-4fe22eed50ce7c45da30b0efc6106b90281ff5f5.tar.gz
portmap_6.0: Fix building on mipsel with gcc4.3
with gcc-4.4 and provides the following: | tmp/cross/mipsel/lib/gcc/mipsel-angstrom-linux/4.4.1/../../../../mipsel-angstrom-linux/bin/ld: portmap.o: relocation R_MIPS_HI16 against `__gnu_local_gp' can not be used when making a shared object; recompile with -fPIC The CFLAGS in portmap's Makefile contains -fpie, but is ignored. The CFLAGS I've added below are constructed from portmap's Makefile. When built with gcc-4.3.3 the resultant binary no longer segfaults. Signed-Off-By: Holger Hans Peter Freyther <zecke@selfish.org>
Diffstat (limited to 'recipes/portmap/portmap-6.0')
-rw-r--r--recipes/portmap/portmap-6.0/no-pie.patch14
1 files changed, 0 insertions, 14 deletions
diff --git a/recipes/portmap/portmap-6.0/no-pie.patch b/recipes/portmap/portmap-6.0/no-pie.patch
deleted file mode 100644
index 4d7e2daae4..0000000000
--- a/recipes/portmap/portmap-6.0/no-pie.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- portmap_6.0/Makefile.orig 2007-11-21 00:35:52.000000000 -0600
-+++ portmap_6.0/Makefile 2007-11-21 00:37:23.000000000 -0600
-@@ -125,9 +125,9 @@
- all: portmap pmap_dump pmap_set portmap.man
-
- CPPFLAGS += $(HOSTS_ACCESS)
--portmap: CFLAGS += -fpie
-+#portmap: CFLAGS += -fpie
- portmap: LDLIBS += $(WRAP_LIB)
--portmap: LDFLAGS += -pie
-+#portmap: LDFLAGS += -pie
- portmap: portmap.o pmap_check.o from_local.o
-
- from_local: CPPFLAGS += -DTEST