aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pmount/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pmount/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pmount/files')
-rw-r--r--recipes/pmount/files/mmc-fix.patch20
-rw-r--r--recipes/pmount/files/no-hal.patch11
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes/pmount/files/mmc-fix.patch b/recipes/pmount/files/mmc-fix.patch
new file mode 100644
index 0000000000..3376a503c7
--- /dev/null
+++ b/recipes/pmount/files/mmc-fix.patch
@@ -0,0 +1,20 @@
+--- pmount-0.9.4/policy.c.orig 2005-09-22 23:11:29 +0200
++++ pmount-0.9.4/policy.c 2005-09-22 23:12:54 +0200
+@@ -354,7 +354,7 @@
+ device_removable( const char* device )
+ {
+ struct sysfs_device *dev;
+- static char* hotplug_buses[] = { "usb", "ieee1394", NULL };
++ static char* hotplug_buses[] = { "usb", "ieee1394", "mmc", NULL };
+ int removable;
+ char blockdevpath[PATH_MAX];
+
+@@ -370,7 +370,7 @@
+ /* check whether device has "removable" attribute with value '1' */
+ removable = get_blockdev_attr( blockdevpath, "removable" );
+
+- /* if not, fall back to bus scanning (regard USB and FireWire as removable) */
++ /* if not, fall back to bus scanning (regard USB, FireWire and MMC as removable) */
+ if( !removable )
+ removable = find_bus_ancestry( dev, hotplug_buses );
+ sysfs_close_device( dev );
diff --git a/recipes/pmount/files/no-hal.patch b/recipes/pmount/files/no-hal.patch
new file mode 100644
index 0000000000..0deffdee5d
--- /dev/null
+++ b/recipes/pmount/files/no-hal.patch
@@ -0,0 +1,11 @@
+--- pmount-0.9.4/Makefile.orig 2005-09-22 15:43:39 +0200
++++ pmount-0.9.4/Makefile 2005-09-22 15:43:52 +0200
+@@ -9,7 +9,7 @@
+ pumount_OBJ = pumount.o policy.o utils.o luks.o
+ pmount_hal_OBJ = pmount-hal.o policy.o utils.o fs.o
+
+-all: pmount pumount pmount-hal po/pmount.pot
++all: pmount pumount po/pmount.pot
+
+ pmount: $(pmount_OBJ)
+ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@