aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/perl_5.8.8.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-05-07 17:11:31 +0200
committerKoen Kooi <koen@openembedded.org>2010-05-07 17:11:31 +0200
commitfe4ff6940b06c73d5b88224b99750bf65accf13d (patch)
tree3aa035f1f16bdb035352d3e874254065e6b5a68b /recipes/perl/perl_5.8.8.bb
parentaa5af845e4ea47c0423fb845b3a60d3123d33d68 (diff)
downloadopenembedded-fe4ff6940b06c73d5b88224b99750bf65accf13d.tar.gz
perl: change 'cp' to 'ln' to fix perl build issues, thanks to Tom Rini for the suggestion
Diffstat (limited to 'recipes/perl/perl_5.8.8.bb')
-rw-r--r--recipes/perl/perl_5.8.8.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 3dae957e1a..5717d009f3 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r32"
+PR = "r34"
# Major part of version
PVM = "5.8"
@@ -54,7 +54,7 @@ export LDDLFLAGS = "${LDFLAGS} -shared"
do_configure() {
# Make hostperl in build directory be the native perl
- cp -f ${HOSTPERL} hostperl
+ ln -sf ${HOSTPERL} hostperl
# Do out work in the cross subdir
cd Cross