summaryrefslogtreecommitdiffstats
path: root/recipes/perl/perl_5.10.1.bb
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-11-22 17:23:55 +0300
committerRoman I Khimov <khimov@altell.ru>2010-12-28 22:50:40 +0300
commit264f7ab1f41cc86d29716619d67506c85223df71 (patch)
treecda0ceeaa1ef59fc6bd4e3f97e76e2ab2fade228 /recipes/perl/perl_5.10.1.bb
parent228a1481110bf8e522baca11fef3d682648236fd (diff)
downloadopenembedded-264f7ab1f41cc86d29716619d67506c85223df71.tar.gz
perl: fix PERLCONFIGTARGET for multimach builds, move cpan vars
Multimachine builds race staging Config_heavy-target.pl to native directory. Solve that by changing PERLCONFIGTARGET variable semantics, now it will contain $TARGET_SYS. Change perl patch and stage functions accordingly. Also, move PERLCONFIGTARGET and other target-specific variable settings from cpan to cpan-base as I think they're also useful for cpan_build and anywhere else cpan-base is needed. Signed-off-by: Roman I Khimov <khimov@altell.ru> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/perl/perl_5.10.1.bb')
-rw-r--r--recipes/perl/perl_5.10.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index 91434e284a..387755e4da 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPLv1+"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r14"
+PR = "r15"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -211,7 +211,7 @@ do_stage() {
# target config, used by cpan.bbclass to extract version information
install config.sh ${STAGING_LIBDIR}/perl/
# target configuration, used by native perl when cross-compiling
- install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
+ install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-${TARGET_SYS}.pl
# target configuration
install lib/Config.pm ${STAGING_LIBDIR}/perl/${PV}/
install lib/ExtUtils/typemap ${STAGING_DATADIR}/perl/${PV}/ExtUtils/