summaryrefslogtreecommitdiffstats
path: root/recipes/perl/libdevice-serialport-perl_1.04.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-01-01 19:16:50 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-01-01 19:16:50 +0100
commitb571bb5050a40a4359b5ef87531e419c8aa22819 (patch)
treedc432faead6e01adfa8cbabf5016aa1856fd4c19 /recipes/perl/libdevice-serialport-perl_1.04.bb
parentae17fce816b0087593cf767a8ae2d02ebda4edb2 (diff)
downloadopenembedded-b571bb5050a40a4359b5ef87531e419c8aa22819.tar.gz
perl/lib*: removed most -native recipes,
added BBCLASSEXTEND to the non-native recipes to automatically create the native recipes
Diffstat (limited to 'recipes/perl/libdevice-serialport-perl_1.04.bb')
-rw-r--r--recipes/perl/libdevice-serialport-perl_1.04.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes/perl/libdevice-serialport-perl_1.04.bb b/recipes/perl/libdevice-serialport-perl_1.04.bb
index 8f4b0a657f..8d193f4afa 100644
--- a/recipes/perl/libdevice-serialport-perl_1.04.bb
+++ b/recipes/perl/libdevice-serialport-perl_1.04.bb
@@ -3,6 +3,7 @@ LICENSE = "GPL"
RDEPENDS += "perl-module-carp perl-module-posix perl-module-io-handle \
perl-module-strict perl-module-warnings perl-module-vars \
perl-module-xsloader"
+PR= "r1"
SRC_URI = "http://www.cpan.org/modules/by-module/Device/Device-SerialPort-${PV}.tar.gz"
@@ -17,3 +18,5 @@ do_configure_prepend () {
autoreconf -Wcross --verbose --install --force || oefatal "autoreconf execution failed."
sed -i 's:\./configure\(.[^-]\):./configure --build=${BUILD_SYS} --host=${HOST_SYS} --target=${TARGET_SYS} --prefix=${prefix} --exec_prefix=${exec_prefix} --bindir=${bindir} --sbindir=${sbindir} --libexecdir=${libexecdir} --datadir=${datadir} --sysconfdir=${sysconfdir} --sharedstatedir=${sharedstatedir} --localstatedir=${localstatedir} --libdir=${libdir} --includedir=${includedir} --oldincludedir=${oldincludedir} --infodir=${infodir} --mandir=${mandir}\1:' Makefile.PL
}
+
+BBCLASSEXTEND="native"