aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openssl
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-11-20 22:55:15 -0800
committerKhem Raj <raj.khem@gmail.com>2010-11-20 22:57:42 -0800
commit138a26eca087e62f2bc1c38e262eba14f9a9ec91 (patch)
tree21cce8850d0eab11c358721b66e7b3c86b716c0c /recipes/openssl
parent3770a5951dfbd2f75679f352cdcec7329dab9bb9 (diff)
downloadopenembedded-138a26eca087e62f2bc1c38e262eba14f9a9ec91.tar.gz
openssl: Add mips64{el}-linux target awareness
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/openssl')
-rw-r--r--recipes/openssl/openssl-0.9.8m/configure-targets.patch22
-rw-r--r--recipes/openssl/openssl-1.0.0b/configure-targets.patch14
-rw-r--r--recipes/openssl/openssl-native_0.9.8m.bb2
-rw-r--r--recipes/openssl/openssl-native_1.0.0b.bb2
-rw-r--r--recipes/openssl/openssl_0.9.8m.bb2
-rw-r--r--recipes/openssl/openssl_1.0.0b.bb2
6 files changed, 32 insertions, 12 deletions
diff --git a/recipes/openssl/openssl-0.9.8m/configure-targets.patch b/recipes/openssl/openssl-0.9.8m/configure-targets.patch
index b68123a233..fbd63576ec 100644
--- a/recipes/openssl/openssl-0.9.8m/configure-targets.patch
+++ b/recipes/openssl/openssl-0.9.8m/configure-targets.patch
@@ -1,11 +1,19 @@
The number of colons are important :)
-Index: openssl-0.9.8g/Configure
+Index: openssl-0.9.8m/Configure
===================================================================
---- openssl-0.9.8g.orig/Configure 2008-04-12 04:27:22.000000000 +0200
-+++ openssl-0.9.8g/Configure 2008-04-12 04:38:56.000000000 +0200
-@@ -395,6 +395,16 @@
+--- openssl-0.9.8m.orig/Configure
++++ openssl-0.9.8m/Configure
+@@ -253,7 +253,6 @@ my %table=(
+ # N64 ABI builds.
+ "irix64-mips4-gcc","gcc:-mabi=64 -mips4 -O3 -DTERMIOS -DB_ENDIAN -DBN_DIV3W::-D_SGI_MP_SOURCE:::RC4_CHAR RC4_CHUNK DES_RISC2 DES_UNROLL SIXTY_FOUR_BIT_LONG::bn-mips3.o::::::::::dlfcn:irix-shared::-mabi=64:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+ "irix64-mips4-cc", "cc:-64 -mips4 -O2 -use_readonly_const -G0 -rdata_shared -DTERMIOS -DB_ENDIAN -DBN_DIV3W::-D_SGI_MP_SOURCE:::RC4_CHAR RC4_CHUNK DES_RISC2 DES_UNROLL SIXTY_FOUR_BIT_LONG::bn-mips3.o::::::::::dlfcn:irix-shared::-64:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+-
+ #### Unified HP-UX ANSI C configs.
+ # Special notes:
+ # - Originally we were optimizing at +O4 level. It should be noted
+@@ -371,6 +370,22 @@ my %table=(
"linux-alpha-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${no_asm}",
"linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${no_asm}",
@@ -18,6 +26,12 @@ Index: openssl-0.9.8g/Configure
+"linux-uclibcgnueabi-armeb","$ENV{'CC'}:-DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+
+"linux-avr32","$ENV{'CC'}:-DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).",
++####
++
++"linux-mips","$ENV{'CC'}:-DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"linux-mips64","$ENV{'CC'}:-DB_ENDIAN -DTERMIO -mabi=64 -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"linux-mips64el","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -mabi=64 -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"linux-mipsel","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+
#### *BSD [do see comment about ${BSDthreads} above!]
"BSD-generic32","gcc:-DTERMIOS -O3 -fomit-frame-pointer -Wall::${BSDthreads}:::BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL:${no_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
diff --git a/recipes/openssl/openssl-1.0.0b/configure-targets.patch b/recipes/openssl/openssl-1.0.0b/configure-targets.patch
index 112732b3fd..22f8743e7f 100644
--- a/recipes/openssl/openssl-1.0.0b/configure-targets.patch
+++ b/recipes/openssl/openssl-1.0.0b/configure-targets.patch
@@ -2,11 +2,11 @@
The number of colons are important :)
-Index: openssl-1.0.0/Configure
+Index: openssl-1.0.0a/Configure
===================================================================
---- openssl-1.0.0.orig/Configure 2010-01-19 13:40:54.000000000 -0800
-+++ openssl-1.0.0/Configure 2010-05-26 22:58:01.238104854 -0700
-@@ -380,6 +380,16 @@ my %table=(
+--- openssl-1.0.0a.orig/Configure
++++ openssl-1.0.0a/Configure
+@@ -380,6 +380,22 @@ my %table=(
"linux-alpha-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
"linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
@@ -20,6 +20,12 @@ Index: openssl-1.0.0/Configure
+
+"linux-avr32","$ENV{'CC'}:-DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).",
+
++#### Linux on MIPS/MIPS64
++"linux-mips","$ENV{'CC'}:-DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"linux-mips64","$ENV{'CC'}:-DB_ENDIAN -DTERMIO -mabi=64 -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"linux-mips64el","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -mabi=64 -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"linux-mipsel","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++
#### *BSD [do see comment about ${BSDthreads} above!]
"BSD-generic32","gcc:-DTERMIOS -O3 -fomit-frame-pointer -Wall::${BSDthreads}:::BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL:${no_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
"BSD-x86", "gcc:-DL_ENDIAN -DTERMIOS -O3 -fomit-frame-pointer -Wall::${BSDthreads}:::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_asm}:a.out:dlfcn:bsd-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
diff --git a/recipes/openssl/openssl-native_0.9.8m.bb b/recipes/openssl/openssl-native_0.9.8m.bb
index 1b82645b78..2b955733af 100644
--- a/recipes/openssl/openssl-native_0.9.8m.bb
+++ b/recipes/openssl/openssl-native_0.9.8m.bb
@@ -4,7 +4,7 @@ inherit pkgconfig native
SRC_URI[src.md5sum] = "898bf125370926d5f692a2201124f8ec"
SRC_URI[src.sha256sum] = "36037160281cf4977d964e403d2bc0680fbca0a7ff9f65e33136d75fae12cb5b"
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
# This flag can contain target options (e.g -mfpu=neon for armv7-a systems)
export FULL_OPTIMIZATION = " "
diff --git a/recipes/openssl/openssl-native_1.0.0b.bb b/recipes/openssl/openssl-native_1.0.0b.bb
index 4ad4936b20..3da055d7d5 100644
--- a/recipes/openssl/openssl-native_1.0.0b.bb
+++ b/recipes/openssl/openssl-native_1.0.0b.bb
@@ -4,7 +4,7 @@ inherit pkgconfig native
SRC_URI[src.md5sum] = "104deb3b7e6820cae6de3f49ba0ff2b0"
SRC_URI[src.sha256sum] = "4e7b4e2fb33ee2d97c5e143561ab495dbbfc08f0a863e617a0c7adca19017331"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/openssl/openssl_0.9.8m.bb b/recipes/openssl/openssl_0.9.8m.bb
index a7eb332857..4453a73dcc 100644
--- a/recipes/openssl/openssl_0.9.8m.bb
+++ b/recipes/openssl/openssl_0.9.8m.bb
@@ -4,7 +4,7 @@ require openssl.inc
SRC_URI[src.md5sum] = "898bf125370926d5f692a2201124f8ec"
SRC_URI[src.sha256sum] = "36037160281cf4977d964e403d2bc0680fbca0a7ff9f65e33136d75fae12cb5b"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
export OE_LDFLAGS="${LDFLAGS}"
diff --git a/recipes/openssl/openssl_1.0.0b.bb b/recipes/openssl/openssl_1.0.0b.bb
index 13236a4b24..ee333712f7 100644
--- a/recipes/openssl/openssl_1.0.0b.bb
+++ b/recipes/openssl/openssl_1.0.0b.bb
@@ -4,7 +4,7 @@ require openssl.inc
SRC_URI[src.md5sum] = "104deb3b7e6820cae6de3f49ba0ff2b0"
SRC_URI[src.sha256sum] = "4e7b4e2fb33ee2d97c5e143561ab495dbbfc08f0a863e617a0c7adca19017331"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "-1"