aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openssl/openssl-1.0.0e/parallel-make-fix.patch
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf_samuelsson@telia.com>2011-10-21 13:59:05 +0200
committerUlf Samuelsson <ulf_samuelsson@telia.com>2011-11-21 15:54:20 +0100
commitbd6916a6b0cc44a2ee694ee4f9fca09fa5d2e2a3 (patch)
tree3dbf514e1dd7ea9dff90a9dff707e28eae8fe865 /recipes/openssl/openssl-1.0.0e/parallel-make-fix.patch
parentbe7fc55acccef17b90057f1cdec2479f5c6cb3af (diff)
downloadopenembedded-bd6916a6b0cc44a2ee694ee4f9fca09fa5d2e2a3.tar.gz
openssl-1.0.0d: Update to openssl-1.0.0e
Backported from openembedded-core meta-openembedded/meta-oe/recipes-connectivity/openssl Signed-Off-By: Ulf Samuelsson <ulf_samuelsson@telia.com>
Diffstat (limited to 'recipes/openssl/openssl-1.0.0e/parallel-make-fix.patch')
-rw-r--r--recipes/openssl/openssl-1.0.0e/parallel-make-fix.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/openssl/openssl-1.0.0e/parallel-make-fix.patch b/recipes/openssl/openssl-1.0.0e/parallel-make-fix.patch
new file mode 100644
index 0000000000..7ba9348704
--- /dev/null
+++ b/recipes/openssl/openssl-1.0.0e/parallel-make-fix.patch
@@ -0,0 +1,20 @@
+Upstream-Status: Submitted
+
+fix the parallel build regarding shared libraries.
+
+Signed-off-by: Qing He <qing.he@intel.com>
+
+Index: openssl-1.0.0d/Makefile.org
+===================================================================
+--- openssl-1.0.0d.orig/Makefile.org 2010-01-27 08:06:58.000000000 -0800
++++ openssl-1.0.0d/Makefile.org 2011-08-06 17:51:04.448556931 -0700
+@@ -258,6 +258,9 @@
+ build_testapps:
+ @dir=crypto; target=testapps; $(BUILD_ONE_CMD)
+
++libcrypto.a: build_crypto
++ libssl.a: build_ssl
++
+ libcrypto$(SHLIB_EXT): libcrypto.a
+ @if [ "$(SHLIB_TARGET)" != "" ]; then \
+ $(MAKE) SHLIBDIRS=crypto build-shared; \