aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-3rdparty/accelges_svn.bb
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-03-04 16:00:07 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-03-04 16:06:38 +0100
commit1675c832fa1e92891ce73208894b63df67ca7c7a (patch)
tree12252d689a844f70a1af1ba92bd024a0aacbe164 /recipes/openmoko-3rdparty/accelges_svn.bb
parentfcb12f3a4448621ccc75d37dcad4a01820fdf89d (diff)
downloadopenembedded-1675c832fa1e92891ce73208894b63df67ca7c7a.tar.gz
accelges_svn.bb: move to openmoko-3rdparty and make it work again
On recent kernels,the openmoko accelerometers input node moved: /dev/input/event2 -> /dev/input/event3 /dev/input/event3 -> /dev/input/event4 And the reporting format went from relative to absolute. Thanks a lot elisa42 from #openmoko-cdevel on Freenode on irc: <elisa42> GNUtoo|laptop: accelges is probably not working because they use event2/3 which is now event3/4. i think we should report this upstream [...] <elisa42> GNUtoo|laptop: read http://wiki.openmoko.org/wiki/Accelerometer_data_retrieval#Data_structure to understand what rel means Note that upstream doesn't exist anymore: accelges was developped as a google summer of code by someone that now works at Microsoft ( http://www.borza.ro/ for more details) . Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Diffstat (limited to 'recipes/openmoko-3rdparty/accelges_svn.bb')
-rw-r--r--recipes/openmoko-3rdparty/accelges_svn.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes/openmoko-3rdparty/accelges_svn.bb b/recipes/openmoko-3rdparty/accelges_svn.bb
new file mode 100644
index 0000000000..12416b3845
--- /dev/null
+++ b/recipes/openmoko-3rdparty/accelges_svn.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "Openmoko Accelerometer-based Gestures"
+HOMEPAGE = "http://code.google.com/p/accelges/"
+AUTHOR = "Paul V. Borza"
+LICENSE = "GPL"
+SECTION = "openmoko/utilities"
+
+PV = "0.2+svnr${SRCPV}"
+PR = "r5"
+PE = "1"
+SRCREV = "206"
+
+DEPENDS = "curl dbus dbus-glib gtk+ libglade libnotify libxrandr notification-daemon"
+RDEPENDS_${PN} = "notification-daemon"
+
+SRC_URI = "svn://accelges.googlecode.com/svn/;module=trunk;proto=http \
+ file://support_newer_kernels.patch;apply=yes"
+S = "${WORKDIR}/trunk"
+
+inherit autotools update-rc.d
+
+#PACKAGES += "${PN}-cmd"
+
+#INITSCRIPT_PACKAGES = "${PN} ${PN}-cmd"
+#INITSCRIPT_NAME_${PN} = "gesd-neo2"
+#INITSCRIPT_PARAMS_${PN} = "defaults 70"
+#INITSCRIPT_NAME_${PN}-cmd = "gesl"
+#INITSCRIPT_PARAMS_${PN}-cmd = "defaults 80"
+
+INITSCRIPT_NAME = "gesd-neo2"
+INITSCRIPT_PARAMS = "defaults 70"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/accelges/neo2
+ install -c -D -m 644 ${S}/config/neo2/* ${D}${sysconfdir}/accelges/neo2
+ install -d ${D}${sysconfdir}/accelges/neo3
+ install -c -D -m 644 ${S}/config/neo3/* ${D}${sysconfdir}/accelges/neo3
+ install -d ${D}${sysconfdir}/accelges/wii
+ install -c -D -m 644 ${S}/config/wii/* ${D}${sysconfdir}/accelges/wii
+
+ install -d ${D}${sysconfdir}/init.d
+ install -c -D -m 755 ${S}/config/init.d/* ${D}${sysconfdir}/init.d/
+
+ install -d ${D}${sysconfdir}/dbus-1/system.d
+ install -c -D -m 644 ${S}/gesd/data/accelges.conf ${D}${sysconfdir}/dbus-1/system.d
+}
+
+# FIXME increase packaging granularity
+FILES_${PN} += "${datadir}"
+