aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opencv/opencv_1.0.0.bb
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/opencv/opencv_1.0.0.bb
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/opencv/opencv_1.0.0.bb')
-rw-r--r--recipes/opencv/opencv_1.0.0.bb36
1 files changed, 18 insertions, 18 deletions
diff --git a/recipes/opencv/opencv_1.0.0.bb b/recipes/opencv/opencv_1.0.0.bb
index b696323214..32ca2d079e 100644
--- a/recipes/opencv/opencv_1.0.0.bb
+++ b/recipes/opencv/opencv_1.0.0.bb
@@ -10,24 +10,24 @@ DEPENDS = "libtool swig swig-native python jpeg zlib libpng tiff glib-2.0"
#RDEPENDS = "python jpeg zlib libpng tiff glib-2.0"
SRC_URI = "${SOURCEFORGE_MIRROR}/opencvlibrary/opencv-${PV}.tar.gz \
- file://debian/010_enable_static.diff;apply=yes \
- file://debian/010_ffmpeg_linking.diff;apply=yes \
- file://debian/010_fix_optimisations.diff;apply=yes \
- file://debian/010_m4_syntax.diff;apply=yes \
- file://debian/010_makefile_syntax.diff;apply=yes \
- file://debian/010_python_cspec.diff;apply=yes \
- file://debian/020_python_linking.diff;apply=yes \
- file://debian/030_install_hook.diff;apply=yes \
- file://debian/050_rebootstrap.diff;apply=yes \
- file://debian/100_amd64.diff;apply=yes \
- file://debian/100_static_inline.diff;apply=yes \
- file://debian/100_ffmpeg_updates.diff;apply=yes \
- file://debian/110_dc1394.diff;apply=yes \
- file://debian/120_header_warnings.diff;apply=yes \
- file://debian/200_documentation.diff;apply=yes \
- file://debian/200_examples_makefile.diff;apply=yes \
- file://debian/210_openmp_compilation.diff;apply=yes \
- file://debian/300_fix_segfault_in_window_gtk.diff;apply=yes \
+ file://debian/010_enable_static.diff \
+ file://debian/010_ffmpeg_linking.diff \
+ file://debian/010_fix_optimisations.diff \
+ file://debian/010_m4_syntax.diff \
+ file://debian/010_makefile_syntax.diff \
+ file://debian/010_python_cspec.diff \
+ file://debian/020_python_linking.diff \
+ file://debian/030_install_hook.diff \
+ file://debian/050_rebootstrap.diff \
+ file://debian/100_amd64.diff \
+ file://debian/100_static_inline.diff \
+ file://debian/100_ffmpeg_updates.diff \
+ file://debian/110_dc1394.diff \
+ file://debian/120_header_warnings.diff \
+ file://debian/200_documentation.diff \
+ file://debian/200_examples_makefile.diff \
+ file://debian/210_openmp_compilation.diff \
+ file://debian/300_fix_segfault_in_window_gtk.diff \
"
inherit distutils-base autotools pkgconfig