aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/pixdev
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nonworking/pixdev
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nonworking/pixdev')
-rw-r--r--recipes/nonworking/pixdev/pixdev-stable-0.1/braces.patch17
-rw-r--r--recipes/nonworking/pixdev/pixdev-stable_0.1.bb28
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes/nonworking/pixdev/pixdev-stable-0.1/braces.patch b/recipes/nonworking/pixdev/pixdev-stable-0.1/braces.patch
new file mode 100644
index 0000000000..fe390c114a
--- /dev/null
+++ b/recipes/nonworking/pixdev/pixdev-stable-0.1/braces.patch
@@ -0,0 +1,17 @@
+===================================================================
+RCS file: /cvsroot/pixdev/pixdev-stable/include/nxtminput.h,v
+retrieving revision 1.1.1.1
+retrieving revision 1.2
+diff -u -r1.1.1.1 -r1.2
+--- pixdev-stable/include/nxtminput.h 2003/10/10 14:51:12 1.1.1.1
++++ pixdev-stable/include/nxtminput.h 2003/12/06 06:22:41 1.2
+@@ -54,7 +54,8 @@
+ #define MAX_UNITS 4 // Maximum number of units (HH:MM:SS:[am/pm])
+
+ //const char *dayzn[2] = {{"AM"}, {"PM"}}; // Array of either am or pm
+-const short max_val[3] = { {23}, {59}, {59} }; // Max values per unit (23 = hours, 59 = min/sec)
++const short max_val[3] = { 23, 59, 59 };
++// Max values per unit (23 = hours, 59 = min/sec)
+
+
+ /* Forward declarations */
diff --git a/recipes/nonworking/pixdev/pixdev-stable_0.1.bb b/recipes/nonworking/pixdev/pixdev-stable_0.1.bb
new file mode 100644
index 0000000000..78a658d7e7
--- /dev/null
+++ b/recipes/nonworking/pixdev/pixdev-stable_0.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Pixil Operating Environment"
+SECTION = "gui"
+PRIORITY = "optional"
+DEPENDS = "microwindows"
+RDEPENDS = "microwindows"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pixdev/pixdev-stable-${PV}.tar.gz \
+ file://${FILESDIR}/braces.patch;patch=1"
+export EXTRA_OEMAKE=
+
+inherit autotools
+
+do_compile() {
+ if [ "${MACHINE}" = "ipaq" ]; then CONFIG=defconfig_ipaq; fi
+ if [ "${MACHINE}" = "collie" ]; then CONFIG=defconfig_zaurus; fi
+
+ if [ -z "$CONFIG" ]; then CONFIG=defconfig; fi
+
+ oe_runmake $CONFIG
+ oe_runmake MWDIR=${STAGING_DIR_TARGET} "TARGET_CROSS=${TARGET_PREFIX}" all
+}
+
+do_install() {
+ install -d ${D}/${prefix}/pixil
+
+ oe_runmake "TARGET_CROSS=${TARGET_PREFIX}" INSTALL_DIR=${D}/${prefix}/pixil \
+ DEST_DIR=/${prefix}/pixil install
+}