aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/exult
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nonworking/exult
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nonworking/exult')
-rw-r--r--recipes/nonworking/exult/exult_1.2.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes/nonworking/exult/exult_1.2.bb b/recipes/nonworking/exult/exult_1.2.bb
new file mode 100644
index 0000000000..449bc67eaa
--- /dev/null
+++ b/recipes/nonworking/exult/exult_1.2.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "Exult is a project to create an Ultima 7 game engine that runs on modern operating systems, \
+capable of using the data and graphics files that come with the game. Qt/E based Palmtop Environments Edition w/ SDL"
+SECTION = "opie/games"
+PRIORITY = "optional"
+DEPENDS = "libsdl-qpe libsdl-mixer zlib freetype"
+SRC_URI = "${SOURCEFORGE_MIRROR}/exult/exult-${PV}.tar.gz"
+inherit autotools
+
+#FIXME: Add compatible host or so, it is zaurus specific atm.
+
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+
+EXTRA_OECONF = "-host=arm-embeddix-linux-gnu \
+ --disable-exult-studio-support \
+ --disable-debug \
+ --disable-exult-studio \
+ --disable-gimp-plugin \
+ --disable-tools \
+ --disable-compiler \
+ --enable-data \
+ --disable-timidity \
+ --disable-kmid \
+ --with-vorbis-prefix=${STAGING_LIBDIR}/.. \
+ --with-mpeg2-prefix=${STAGING_LIBDIR}/.. \
+ --with-mad-prefix=${STAGING_BINDIR_CROSS}/.. "
+
+#CXXFLAGS_append = " -Dmain=SDL_main"
+#CFLAGS_append = " -Dmain=SDL_main"
+
+do_install() {
+ install -d ${D}/${palmtopdir}/bin \
+ ${D}/${palmtopdir}/data
+ install -m 0755 exult ${D}/${palmtopdir}/bin/exult
+ install -m 0755 data/exult.flx ${D}/${palmtopdir}/data
+ install -m 0755 data/exult_bg.flx ${D}/${palmtopdir}/data
+ install -m 0755 data/exult_si.flx ${D}/${palmtopdir}/data
+ install -m 0755 data/midisfx.flx ${D}/${palmtopdir}/data
+
+ echo "[Desktop Entry]" >${D}/${palmtopdir}/apps/Games/exult.desktop
+ echo "Comment=Exult game" >>${D}/${palmtopdir}/apps/Games/exult.desktop
+ echo "Exec=exult" >>${D}/${palmtopdir}/apps/Games/exult.desktop
+ echo "Icon=exult" >>${D}/${palmtopdir}/apps/Games/exult.desktop
+ echo "Type=Application" >>${D}/${palmtopdir}/apps/Games/exult.desktop
+ echo "Name=Exult" >>${D}/${palmtopdir}/apps/Games/exult.desktop
+}
+
+FILES_${PN} = "${palmtopdir}"