aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nodejs
diff options
context:
space:
mode:
authorAJ ONeal <coolaj86@gmail.com>2011-02-12 03:01:35 +0000
committerTom Rini <tom_rini@mentor.com>2011-02-11 13:38:47 -0700
commit81e0297498440bce367a540dffb38335a328fbf1 (patch)
treeae673077e9ff9e33df501db20037bc61aa8cea0f /recipes/nodejs
parentbdc4fc779b863ada8fe27d94f3c935929b248810 (diff)
downloadopenembedded-81e0297498440bce367a540dffb38335a328fbf1.tar.gz
nodejs: updated to 0.2.6
* added version number to patches * libev-cross-cc_0.2.6.patch - turns off execution so that cross-compile succeeds * node-cross-cc_0.2.6.patch - enables cross-compiling of v8 for x86, x86_64, arm, and mips Signed-off-by: AJ ONeal <coolaj86@gmail.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/nodejs')
-rw-r--r--recipes/nodejs/files/libev-cross-cc.patch18
-rw-r--r--recipes/nodejs/files/libev-cross-cc_0.2.6.patch13
-rw-r--r--recipes/nodejs/files/node-cross-cc.patch14
-rw-r--r--recipes/nodejs/files/node-cross-cc_0.2.6.patch19
-rw-r--r--recipes/nodejs/nodejs_0.2.6.bb (renamed from recipes/nodejs/nodejs_0.2.1.bb)10
5 files changed, 36 insertions, 38 deletions
diff --git a/recipes/nodejs/files/libev-cross-cc.patch b/recipes/nodejs/files/libev-cross-cc.patch
deleted file mode 100644
index 4dd34f4855..0000000000
--- a/recipes/nodejs/files/libev-cross-cc.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git node-v0.2.1/deps/libev/wscript.orig node-v0.2.1/deps/libev/wscript
-index 19e7bb2..f0a3d3b 100644
---- node-v0.2.1/deps/libev/wscript.orig
-+++ node-v0.2.1/deps/libev/wscript
-@@ -52,7 +52,12 @@ def configure(conf):
- return 0;
- }
- """
-- conf.check_cc(fragment=code, define_name="HAVE_CLOCK_SYSCALL", execute=True,
-+ # TODO determine this dynamically
-+ CROSS = True
-+ execute = True
-+ if CROSS:
-+ execute = False
-+ conf.check_cc(fragment=code, define_name="HAVE_CLOCK_SYSCALL", execute=execute,
- msg="Checking for SYS_clock_gettime")
-
- have_librt = conf.check(lib='rt', uselib_store='RT')
diff --git a/recipes/nodejs/files/libev-cross-cc_0.2.6.patch b/recipes/nodejs/files/libev-cross-cc_0.2.6.patch
new file mode 100644
index 0000000000..13ce4d8b48
--- /dev/null
+++ b/recipes/nodejs/files/libev-cross-cc_0.2.6.patch
@@ -0,0 +1,13 @@
+diff --git node-v0.2.6/deps/libev/wscript.orig node-v0.2.6/deps/libev/wscript
+index 19e7bb2..5ec9143 100644
+--- node-v0.2.6/deps/libev/wscript.orig
++++ node-v0.2.6/deps/libev/wscript
+@@ -52,7 +52,7 @@ def configure(conf):
+ return 0;
+ }
+ """
+- conf.check_cc(fragment=code, define_name="HAVE_CLOCK_SYSCALL", execute=True,
++ conf.check_cc(fragment=code, define_name="HAVE_CLOCK_SYSCALL", execute=False,
+ msg="Checking for SYS_clock_gettime")
+
+ have_librt = conf.check(lib='rt', uselib_store='RT')
diff --git a/recipes/nodejs/files/node-cross-cc.patch b/recipes/nodejs/files/node-cross-cc.patch
deleted file mode 100644
index 0d15afc28a..0000000000
--- a/recipes/nodejs/files/node-cross-cc.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git node-v0.2.1/wscript.orig node-v0.2.1/wscript
-index 9c4243c..3cf6689 100644
---- node-v0.2.1/wscript.orig
-+++ node-v0.2.1/wscript
-@@ -326,6 +326,9 @@ def v8_cmd(bld, variant):
- arch = ""
- if bld.env['DEST_CPU'] == 'x86_64':
- arch = "arch=x64"
-+ # XXX Better support cross-compilation
-+ else:
-+ arch = "arch=" + bld.env['DEST_CPU']
-
- if variant == "default":
- mode = "release"
diff --git a/recipes/nodejs/files/node-cross-cc_0.2.6.patch b/recipes/nodejs/files/node-cross-cc_0.2.6.patch
new file mode 100644
index 0000000000..1087ce2d29
--- /dev/null
+++ b/recipes/nodejs/files/node-cross-cc_0.2.6.patch
@@ -0,0 +1,19 @@
+diff --git node-v0.2.6/wscript.orig node-v0.2.6/wscript
+index a6bade2..566bf5e 100644
+--- node-v0.2.6/wscript.orig
++++ node-v0.2.6/wscript
+@@ -338,6 +338,14 @@ def v8_cmd(bld, variant):
+ arch = ""
+ if bld.env['DEST_CPU'] == 'x86_64':
+ arch = "arch=x64"
++ elif bld.env['DEST_CPU'] == 'x86':
++ arch = "arch=x86"
++ elif bld.env['DEST_CPU'] == 'arm':
++ arch = "arch=arm"
++ elif bld.env['DEST_CPU'] == 'mips':
++ arch = "arch=mips"
++ else:
++ raise Exception(bld.env['DEST_CPU'], "is not one of these supported architectures: x86, x86_64, arm, mips")
+
+ if variant == "default":
+ mode = "release"
diff --git a/recipes/nodejs/nodejs_0.2.1.bb b/recipes/nodejs/nodejs_0.2.6.bb
index c2e9c4163b..76ad993557 100644
--- a/recipes/nodejs/nodejs_0.2.1.bb
+++ b/recipes/nodejs/nodejs_0.2.6.bb
@@ -2,17 +2,15 @@ DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
HOMEPAGE = "http://nodejs.org"
LICENSE = "MIT"
-PR = "r1"
-
DEPENDS = "openssl"
SRC_URI = " \
http://nodejs.org/dist/node-v${PV}.tar.gz \
- file://libev-cross-cc.patch \
- file://node-cross-cc.patch \
+ file://libev-cross-cc_${PV}.patch \
+ file://node-cross-cc_${PV}.patch \
"
-SRC_URI[md5sum] = "c6051dd216817bf0f95bea80c42cf262"
-SRC_URI[sha256sum] = "5bb7d084b2138ce43fcb34739ed894379c450a1dd569a1c710405bc39d2861c2"
+SRC_URI[md5sum] = "b1c50ceb43bee1b221be210b7bc7a216"
+SRC_URI[sha256sum] = "e97fe9c81ff4b569ae9a0d46e64a0572a1f171293573a5b5290bcc3996a19701"
S = "${WORKDIR}/node-v${PV}"