summaryrefslogtreecommitdiffstats
path: root/recipes/mozilla/thunderbird_1.0.7.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/mozilla/thunderbird_1.0.7.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mozilla/thunderbird_1.0.7.bb')
-rw-r--r--recipes/mozilla/thunderbird_1.0.7.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/recipes/mozilla/thunderbird_1.0.7.bb b/recipes/mozilla/thunderbird_1.0.7.bb
new file mode 100644
index 0000000000..c0893068bf
--- /dev/null
+++ b/recipes/mozilla/thunderbird_1.0.7.bb
@@ -0,0 +1,65 @@
+SECTION = "x11/utils"
+DEPENDS += "gnupg"
+RRECOMMENDS += "gnupg"
+PR = "r1"
+
+EMVER="0.92.0"
+IPCVER="1.1.3"
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${PV}/source/thunderbird-${PV}-source.tar.bz2 \
+ http://downloads.mozdev.org/enigmail/src/enigmail-${EMVER}.tar.gz \
+http://downloads.mozdev.org/enigmail/src/ipc-${IPCVER}.tar.gz \
+ file://xptcstubs.patch;patch=1 \
+ file://no-xmb.patch;patch=1 \
+ file://extensions-hack.patch;patch=1 \
+ file://firefox-1.0-gcc4-compile.patch;patch=1;pnum=0 \
+ file://mozilla-thunderbird.png file://mozilla-thunderbird.desktop"
+S = "${WORKDIR}/mozilla"
+
+FILES_${PN} += "${libdir}/thunderbird-${PV}/* ${datadir}/idl"
+FILES_${PN}-dbg += "${libdir}/thunderbird-${PV}/.debug*"
+
+inherit mozilla
+
+export MOZ_THUNDERBIRD="1"
+
+do_configure() {
+ for x in ipc enigmail; do
+ if [ ! -e ${WORKDIR}/mozilla/extensions/$x ]; then
+ mv ${WORKDIR}/$x ${WORKDIR}/mozilla/extensions/
+ cd ${WORKDIR}/mozilla/extensions/$x
+ makemake
+ fi
+ done
+ cd ${S}
+ mozilla_do_configure
+}
+
+do_compile() {
+ mozilla_do_compile
+ oe_runmake -C ${WORKDIR}/mozilla/extensions/ipc
+ oe_runmake -C ${WORKDIR}/mozilla/extensions/enigmail
+}
+
+do_install() {
+ mozilla_do_install
+ oe_runmake -C ${WORKDIR}/mozilla/extensions/ipc DESTDIR="${D}" install
+ oe_runmake -C ${WORKDIR}/mozilla/extensions/enigmail DESTDIR="${D}" install
+ install -d ${D}${datadir}/applications
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/mozilla-thunderbird.desktop ${D}${datadir}/applications/
+ install -m 0644 ${WORKDIR}/mozilla-thunderbird.png ${D}${datadir}/pixmaps/
+}
+
+pkg_postinst_thunderbird() {
+ chmod -R a+w ${libdir}/thunderbird*
+}
+
+# Simulate the silly csh makemake script
+makemake() {
+ typeset m topdir
+ for m in $(find . -name Makefile.in); do
+ topdir=$(echo "$m" | sed -r 's:[^/]+:..:g')
+ sed -e "s:@srcdir@:.:g" -e "s:@top_srcdir@:${topdir}:g" \
+ < ${m} > ${m%.in} || die "sed ${m} failed"
+ done
+}