aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla/firefox
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-01 12:14:34 +0200
committerKoen Kooi <koen@openembedded.org>2009-10-01 13:12:00 +0200
commit1fb6ea09d2c75b67627835aa3d055df5e168ca29 (patch)
tree434bf68c46b9b04e2fe529cd7b0a997153f1aa7c /recipes/mozilla/firefox
parent96f8ec7a61658573adf438763f392bccc8c6f3c7 (diff)
downloadopenembedded-1fb6ea09d2c75b67627835aa3d055df5e168ca29.tar.gz
firefox 3.5.2: sync with AlwaysInnovating overlay
Diffstat (limited to 'recipes/mozilla/firefox')
-rw-r--r--recipes/mozilla/firefox/firefox-plugin.pc10
-rw-r--r--recipes/mozilla/firefox/firefox-xpcom.pc13
-rw-r--r--recipes/mozilla/firefox/jsautocfg-dontoverwrite.patch23
-rw-r--r--recipes/mozilla/firefox/mozconfig66
-rw-r--r--recipes/mozilla/firefox/nspr.pc10
5 files changed, 122 insertions, 0 deletions
diff --git a/recipes/mozilla/firefox/firefox-plugin.pc b/recipes/mozilla/firefox/firefox-plugin.pc
new file mode 100644
index 0000000000..611acd5944
--- /dev/null
+++ b/recipes/mozilla/firefox/firefox-plugin.pc
@@ -0,0 +1,10 @@
+prefix=/usr
+exec_prefix=/usr
+libdir=/usr/lib
+includedir=/usr/include/firefox-3.5.2
+
+Name: Mozilla Plug-In API
+Description: Mozilla Plug-In API
+Version: 3.5
+Requires: firefox-xpcom = 3.5
+Cflags: -I${includedir}/java -I${includedir}/plugin
diff --git a/recipes/mozilla/firefox/firefox-xpcom.pc b/recipes/mozilla/firefox/firefox-xpcom.pc
new file mode 100644
index 0000000000..935d357d84
--- /dev/null
+++ b/recipes/mozilla/firefox/firefox-xpcom.pc
@@ -0,0 +1,13 @@
+prefix=/usr
+exec_prefix=/usr
+libdir=/usr/lib
+includedir=/usr/include
+mozdir=${includedir}/firefox-3.5.2
+idldir=${includedir}/firefox-3.5.2
+
+Name: XPCOM
+Description: The Mozilla Cross Platform Component Library
+Version: 3.5
+Requires: nspr >= 4.8
+Libs: -L${libdir} -lxpcom -Wl,-R${libdir}
+Cflags: -I${mozdir} -I${mozdir}/xpcom -I${mozdir}/string
diff --git a/recipes/mozilla/firefox/jsautocfg-dontoverwrite.patch b/recipes/mozilla/firefox/jsautocfg-dontoverwrite.patch
new file mode 100644
index 0000000000..b3188de32f
--- /dev/null
+++ b/recipes/mozilla/firefox/jsautocfg-dontoverwrite.patch
@@ -0,0 +1,23 @@
+--- /tmp/Makefile.in 2009-03-20 10:34:54.000000000 +0100
++++ mozilla-central/js/src/Makefile.in 2009-03-20 10:35:18.000000000 +0100
+@@ -507,20 +507,8 @@
+
+ export:: jsautocfg.h
+
+-ifeq (,$(CROSS_COMPILE)$(GNU_CC)$(filter-out WINNT,$(OS_ARCH)))
+-jsautocfg.h:
+- touch $@
+-else
+-ifeq ($(OS_ARCH),WINCE)
+ jsautocfg.h:
+ touch $@
+-else
+-jsautocfg.h: jscpucfg$(HOST_BIN_SUFFIX)
+- @rm -f $@ jsautocfg.tmp
+- ./jscpucfg > jsautocfg.tmp
+- mv jsautocfg.tmp $@
+-endif
+-endif
+
+ # jscpucfg is a strange target
+ # Needs to be built with the host compiler but needs to include
diff --git a/recipes/mozilla/firefox/mozconfig b/recipes/mozilla/firefox/mozconfig
new file mode 100644
index 0000000000..f7ab5dd3a3
--- /dev/null
+++ b/recipes/mozilla/firefox/mozconfig
@@ -0,0 +1,66 @@
+. $topsrcdir/browser/config/mozconfig
+
+# use GTK+-2 widget set with XFT font rendering
+#ac_add_options --enable-default-toolkit=gtk2
+ac_add_options --enable-xft
+ac_add_options --disable-freetype2
+
+# enable minimal profile support
+ac_add_options --disable-profilesharing
+ac_add_options --disable-profilelocking
+ac_add_options --enable-single-profile
+
+ac_add_options --with-system-zlib
+ac_add_options --with-system-jpeg
+#ac_add_options --with-system-png
+
+ac_add_options --disable-accessibility
+ac_add_options --disable-composer
+#ac_add_options --enable-plaintext-editor-only
+ac_add_options --disable-mailnews
+ac_add_options --disable-ldap
+#ac_add_options --disable-postscript
+ac_add_options --disable-mathml
+ac_add_options --disable-jsd
+ac_add_options --disable-installer
+ac_add_options --disable-xprint
+ac_add_options --disable-necko-disk-cache
+
+# configure necko to allocate smaller network buffers
+ac_add_options --enable-necko-small-buffers
+
+# disable debug logging and tests
+#ac_add_options --disable-dtd-debug
+ac_add_options --disable-logging
+ac_add_options --disable-gtktest
+ac_add_options --disable-tests
+ac_add_options --disable-printing
+ac_add_options --disable-gnomevfs
+ac_add_options --disable-gnomeui
+ac_add_options --enable-debugger-info-modules
+
+# build crypto module (PSM + NSS)
+ac_add_options --enable-crypto
+
+# build minimal set of protocol handlers
+ac_add_options --enable-necko-protocols=http,file,res,ftp,about,viewsource
+
+# build minimal set of image decoders
+#ac_add_options --enable-image-decoders=png,gif,jpeg
+
+#ac_add_options --enable-reorder
+#ac_add_options --enable-elf-dynstr-gc
+
+# enable static build
+#ac_add_options --disable-shared
+#ac_add_options --enable-static
+ac_add_options --enable-optimize=-O2
+
+# Use cairo from system
+ac_add_options --enable-system-cairo
+
+# Disable jemalloc
+ac_add_options --disable-jemalloc
+
+# enable libxul
+ac_add_options --enable-libxul
diff --git a/recipes/mozilla/firefox/nspr.pc b/recipes/mozilla/firefox/nspr.pc
new file mode 100644
index 0000000000..ba3d131978
--- /dev/null
+++ b/recipes/mozilla/firefox/nspr.pc
@@ -0,0 +1,10 @@
+prefix=/usr
+exec_prefix=/usr
+libdir=/usr/lib
+includedir=/usr/include/firefox-3.5.2
+
+Name: NSPR
+Description: The Netscape Portable Runtime
+Version: 4.8
+Libs: -L${libdir} -lplds4 -lplc4 -lnspr4 -lpthread -ldl -Wl,-R${libdir}
+Cflags: -I${includedir}