aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mono/mono.inc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-27 12:44:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-27 12:44:07 +0200
commit293b05335ab540c4c8402e0a5caf2886b786a318 (patch)
tree11e5a7c2dce338058f150e08d1ff47c9d4d8eccd /recipes/mono/mono.inc
parent1ee2156592ba17f64f3c9b8970285a259730b871 (diff)
parente9aacc4ce4784c91cb4908145b8fb7b3ec8aa6e0 (diff)
downloadopenembedded-293b05335ab540c4c8402e0a5caf2886b786a318.tar.gz
Merge remote branch 'origin/org.openembedded.dev' into shr/testing2010
Conflicts: recipes/linux/linux-openmoko-devel_git.bb recipes/openmoko-3rdparty/pisi_0.5.2.bb recipes/openmoko-3rdparty/pisi_0.5.3.bb recipes/openmoko-3rdparty/pisi_0.5.bb recipes/uclibc/uclibc_nptl.bb
Diffstat (limited to 'recipes/mono/mono.inc')
-rw-r--r--recipes/mono/mono.inc28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/mono/mono.inc b/recipes/mono/mono.inc
new file mode 100644
index 0000000000..c1e80a416a
--- /dev/null
+++ b/recipes/mono/mono.inc
@@ -0,0 +1,28 @@
+DESCRIPTION = "Mono Programming Language"
+SECTION = "devel/mono"
+LICENSE = "GPL LGPL X11"
+
+SRC_URI = "http://ftp.novell.com/pub/mono/sources/mono/mono-${PV}.tar.bz2"
+
+INC_PR = "r0"
+
+S = "${WORKDIR}/mono-${PV}"
+CFLAGS_append += " -DARM_FPU_NONE=1 "
+# parallel make does not work for mono (currently)
+
+PARALLEL_MAKE = ""
+
+do_fix_dolt_libtool() {
+ # look for libtool prefixed with HOST_SYS
+ sed -e "s/slash\}libtool/slash\}${HOST_SYS}-libtool/" -i acinclude.m4
+ echo No acinclude!
+ libtoolize --force --copy
+}
+
+inherit autotools
+EXTRA_OECONF_arm = "--without-tls"
+EXTRA_OECONF_mipsel = "--without-tls"
+
+addtask fix_dolt_libtool after do_patch before do_configure
+
+