aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mesa/mesa-dri_7.6.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-12-16 09:12:09 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-12-16 09:12:09 +0100
commit5452b155e112c43887c009f633b36ce72e2adf35 (patch)
treefc110d646a658e9b1dfc4260dfa90a34f9313ee6 /recipes/mesa/mesa-dri_7.6.bb
parent47d6cb217ff161738488f4f82af9dd8f8c616ce0 (diff)
downloadopenembedded-5452b155e112c43887c009f633b36ce72e2adf35.tar.gz
mesa: add 7.6 from xorg-7.5 branch, update git version with different SRC_URI for om-gta02 (glamo patches)
Diffstat (limited to 'recipes/mesa/mesa-dri_7.6.bb')
-rw-r--r--recipes/mesa/mesa-dri_7.6.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/mesa/mesa-dri_7.6.bb b/recipes/mesa/mesa-dri_7.6.bb
new file mode 100644
index 0000000000..0eed2ef8d4
--- /dev/null
+++ b/recipes/mesa/mesa-dri_7.6.bb
@@ -0,0 +1,28 @@
+include mesa-common.inc
+
+PROTO_DEPS = "xf86driproto glproto dri2proto expat"
+LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes"
+
+DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
+ ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaDemos-${PV}.tar.bz2 \
+ "
+PE = "1"
+PR = "${INC_PR}.0"
+
+# most of our targets do not have DRI so will use mesa-xlib
+DEFAULT_PREFERENCE = "-1"
+
+DEFAULT_PREFERENCE_om-gta01 = "2"
+
+# ASUS EeePC 901 has DRI support so use mesa-dri by default
+DEFAULT_PREFERENCE_eee901 = "1"
+
+PACKAGES =+ "${PN}-xprogs"
+
+FILES_${PN} += "${libdir}/dri/*.so"
+FILES_${PN}-dbg += "${libdir}/dri/.debug/*"
+FILES_${PN}-xprogs = "${bindir}/glxdemo ${bindir}/glxgears ${bindir}/glxheads ${bindir}/glxinfo"
+
+EXTRA_OECONF += "--disable-gallium --with-driver=dri --with-dri-drivers=swrast,${MACHINE_DRI_MODULES}"