aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ltrace/files/ltrace-mips.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-10-24 12:04:44 -0700
committerKhem Raj <raj.khem@gmail.com>2009-10-24 12:09:44 -0700
commitb85b779688f0abc389e3c25d06b54de8b86385c1 (patch)
tree83a4173112903373c1f5738d91bdacdf2a8b3f3b /recipes/ltrace/files/ltrace-mips.patch
parent9d3d1de150b7dd43a6dd3f8f5a87e88b5154102e (diff)
downloadopenembedded-b85b779688f0abc389e3c25d06b54de8b86385c1.tar.gz
ltrace_0.5.3.bb: New recipe for 0.5.3
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/ltrace/files/ltrace-mips.patch')
-rw-r--r--recipes/ltrace/files/ltrace-mips.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/ltrace/files/ltrace-mips.patch b/recipes/ltrace/files/ltrace-mips.patch
new file mode 100644
index 0000000000..6df5e211a1
--- /dev/null
+++ b/recipes/ltrace/files/ltrace-mips.patch
@@ -0,0 +1,36 @@
+Index: ltrace-0.5.3/sysdeps/linux-gnu/mipsel/plt.c
+===================================================================
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/mipsel/plt.c 2009-10-23 23:25:59.292780574 -0700
++++ ltrace-0.5.3/sysdeps/linux-gnu/mipsel/plt.c 2009-10-23 23:26:22.671522220 -0700
+@@ -1,4 +1,4 @@
+-#include <debug.h>
++#include "debug.h"
+ #include <gelf.h>
+ #include <sys/ptrace.h>
+ #include "common.h"
+Index: ltrace-0.5.3/sysdeps/linux-gnu/mipsel/regs.c
+===================================================================
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/mipsel/regs.c 2009-10-23 23:25:59.312777529 -0700
++++ ltrace-0.5.3/sysdeps/linux-gnu/mipsel/regs.c 2009-10-23 23:26:08.190311896 -0700
+@@ -4,7 +4,6 @@
+ #include <sys/types.h>
+ #include <sys/ptrace.h>
+ #include <asm/ptrace.h>
+-#include <linux/user.h>
+
+ #include "common.h"
+ #include "mipsel.h"
+Index: ltrace-0.5.3/handle_event.c
+===================================================================
+--- ltrace-0.5.3.orig/handle_event.c 2009-10-23 23:29:48.780274445 -0700
++++ ltrace-0.5.3/handle_event.c 2009-10-23 23:37:32.260284055 -0700
+@@ -573,7 +573,8 @@ handle_breakpoint(Event *event) {
+ void *old_addr;
+ struct library_symbol *sym= event->proc->callstack[i].c_un.libfunc;
+ assert(sym);
+- old_addr = dict_find_entry(event->proc->breakpoints, sym2addr(event->proc, sym))->addr;
++ struct Breakpoint *tbp = dict_find_entry(event->proc->breakpoints, sym2addr(event->proc, sym));
++ old_addr = tbp->addr;
+ addr=sym2addr(event->proc,sym);
+ assert(old_addr !=0 && addr !=0);
+ if(addr != old_addr){