aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm/llvm2.7
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2010-06-11 13:20:00 +0200
committerRobert Schuster <robertschuster@fsfe.org>2010-06-11 13:21:21 +0200
commit5356193d0f64dfdb0b9fb500357a183a6f2c2316 (patch)
treeddc21c09cb3090412702b6799236b9338da351ef /recipes/llvm/llvm2.7
parenta7bcc78ad94a7cbce2fd5da6fc3f54ae09228f8b (diff)
downloadopenembedded-5356193d0f64dfdb0b9fb500357a183a6f2c2316.tar.gz
llvm.inc: fixed typo.
llvm2.7 2.7: Build with shared library, added patch to work around not correctly linking libgcc.
Diffstat (limited to 'recipes/llvm/llvm2.7')
-rw-r--r--recipes/llvm/llvm2.7/link.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes/llvm/llvm2.7/link.patch b/recipes/llvm/llvm2.7/link.patch
new file mode 100644
index 0000000000..059bd92295
--- /dev/null
+++ b/recipes/llvm/llvm2.7/link.patch
@@ -0,0 +1,12 @@
+Index: llvm-2.7/tools/llvm-shlib/Makefile
+===================================================================
+--- llvm-2.7/tools/llvm-shlib/Makefile (revision 103711)
++++ llvm-2.7/tools/llvm-shlib/Makefile (working copy)
+@@ -56,5 +56,5 @@
+ LLVMLibsOptions := -Wl,--whole-archive $(LLVMLibsOptions)
+ -Wl,--no-whole-archive
+ # Don't allow unresolved symbols.
+- LLVMLibsOptions += -Wl,--no-undefined
++ LLVMLibsOptions += -lgcc -Wl,--no-undefined
+ endif
+