aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm/llvm-gcc4-cross_svn.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/llvm/llvm-gcc4-cross_svn.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/llvm/llvm-gcc4-cross_svn.bb')
-rw-r--r--recipes/llvm/llvm-gcc4-cross_svn.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/llvm/llvm-gcc4-cross_svn.bb b/recipes/llvm/llvm-gcc4-cross_svn.bb
new file mode 100644
index 0000000000..9b0e07ab94
--- /dev/null
+++ b/recipes/llvm/llvm-gcc4-cross_svn.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "The Low Level Virtual Machine - gcc4 frontend"
+HOMEPAGE = "http://llvm.org"
+LICENSE = "various"
+
+DEPENDS = "llvm-native"
+
+PV = "2.1+svnr${SRCREV}"
+
+inherit autotools cross
+
+SRC_URI = "svn://anonsvn.opensource.apple.com/svn/llvm/;module=trunk \
+ "
+
+S = "${WORKDIR}/trunk"
+
+EXTRA_OECONF = "--disable-shared \
+ --enable-llvm=/data/build/koen/OE/build/tmp/angstrom/work/i686-linux/llvm-native-2.0-r0/llvm-2.0 \
+ "
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+PARALLEL_MAKE = ""
+
+#oe_runmake gets distracted by GNUMakefiles...
+# we also need to get an install.sh and config-ml.in in gcc/ as well somehow
+do_compile_prepend() {
+ rm -f ${S}/GNUmakefile
+}