summaryrefslogtreecommitdiffstats
path: root/recipes/literki/literki_git.bb
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2010-11-12 00:00:20 -0500
committerCliff Brake <cbrake@bec-systems.com>2010-11-12 00:00:20 -0500
commit3c6efe8f8abc16668ca5e9cdf7a46665dac87172 (patch)
tree642c13416b99e80f0871cdc6668e832e635dfb48 /recipes/literki/literki_git.bb
parentc400c874f2ac9233b8a43a73309b6e7907289c54 (diff)
parent13fbe7253c95881ede787004a4c3a1c31502e5c6 (diff)
downloadopenembedded-3c6efe8f8abc16668ca5e9cdf7a46665dac87172.tar.gz
Merge branch 'master' into testing-nexttested_2010-11-12testing
Diffstat (limited to 'recipes/literki/literki_git.bb')
-rw-r--r--recipes/literki/literki_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/literki/literki_git.bb b/recipes/literki/literki_git.bb
new file mode 100644
index 0000000000..ff497bb5e5
--- /dev/null
+++ b/recipes/literki/literki_git.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Literki overlay keyboard"
+SECTION = "x11"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.opkg.org/package_232.html"
+
+SRCREV = "master"
+PR = "r0.1"
+
+# TODO:
+# steal from http://users.tkk.fi/~tajyrink/moko/literki_mods/
+
+SRC_URI = "git://git.senfdax.de/git/literki;protocol=http"
+SRC_URI += "file://makefile.patch"
+SRC_URI += "file://noswitcher.patch"
+SRC_URI += "file://sliderheight.patch"
+
+PV = "${SRCPV}"
+
+DEPENDS += " \
+ freetype \
+ libxtst \
+ libxext \
+ libxrandr \
+ libpng \
+ libfakekey \
+"
+
+S = "${WORKDIR}/git"
+PACKAGES = "${PN}"
+
+inherit base
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}