aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2011-02-27 16:45:02 +0100
committerSteffen Sledz <sledz@dresearch.de>2011-03-02 08:30:24 +0100
commit4d851d14e48beeb19ec40d2f617e09c3389c1b1a (patch)
tree971f252f594d3926f93196e43ea1915e024acbfc /recipes/linux
parent080b5e2c06a8e23b0a0841026fecb713b3e7378c (diff)
downloadopenembedded-4d851d14e48beeb19ec40d2f617e09c3389c1b1a.tar.gz
linux-kexecboot: pick collie fix from upstream for 2.6.37
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-kexecboot-2.6.37/collie/collie-locomo-kb.patch31
-rw-r--r--recipes/linux/linux-kexecboot_2.6.37.bb4
2 files changed, 34 insertions, 1 deletions
diff --git a/recipes/linux/linux-kexecboot-2.6.37/collie/collie-locomo-kb.patch b/recipes/linux/linux-kexecboot-2.6.37/collie/collie-locomo-kb.patch
new file mode 100644
index 0000000000..8b783e7906
--- /dev/null
+++ b/recipes/linux/linux-kexecboot-2.6.37/collie/collie-locomo-kb.patch
@@ -0,0 +1,31 @@
+ARM: 6658/1: collie: do actually pass locomo_info to locomo driver
+
+locomo_info isn't actually used as a platform_data on collie platform:
+ arm/mach-sa1100/collie.c:237: warning: locomo_info defined but not used
+
+So locomo driver doesn't setup IRQs correctly. Pass locomo_info to the
+driver.
+
+Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
+Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
+---
+ arch/arm/mach-sa1100/collie.c | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/arch/arm/mach-sa1100/collie.c b/arch/arm/mach-sa1100/collie.c
+index d43c5ef..bd3e1bf 100644
+--- a/arch/arm/mach-sa1100/collie.c
++++ b/arch/arm/mach-sa1100/collie.c
+@@ -241,6 +241,9 @@ static struct locomo_platform_data locomo_info = {
+ struct platform_device collie_locomo_device = {
+ .name = "locomo",
+ .id = 0,
++ .dev = {
++ .platform_data = &locomo_info,
++ },
+ .num_resources = ARRAY_SIZE(locomo_resources),
+ .resource = locomo_resources,
+ };
+--
+1.7.4.1
+
diff --git a/recipes/linux/linux-kexecboot_2.6.37.bb b/recipes/linux/linux-kexecboot_2.6.37.bb
index c33ef19396..8cbd84bc2e 100644
--- a/recipes/linux/linux-kexecboot_2.6.37.bb
+++ b/recipes/linux/linux-kexecboot_2.6.37.bb
@@ -1,6 +1,6 @@
require linux-kexecboot.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
S = "${WORKDIR}/linux-${PV}"
@@ -10,5 +10,7 @@ DEFAULT_PREFERENCE = "-1"
SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
file://defconfig"
+SRC_URI_append_collie = " file://collie-locomo-kb.patch;status=upstream "
+
SRC_URI[kernel.md5sum] = "c8ee37b4fdccdb651e0603d35350b434"
SRC_URI[kernel.sha256sum] = "edbf091805414739cf57a3bbfeba9e87f5e74f97e38f04d12060e9e0c71e383a"